Works for a while then fails to load or if it loads then sites don't work

I started with Pressmatic, but barely used it. Then upgraded to Local as prompted.

At some point Local just started hanging on launch. Error log only showed “Pressmatic data does not exist”. I eventually deleted all machines from Virtual Box and uninstalled Local via AppZapper, then reinstalled (a couple days ago) v2.0.4. I re-imported a few sites and that worked for a couple hours, then the sites stopped loading. I would get 500 errors, then eventually (after a few reloads) the error would show Local routing error or something like that.

I really want to like Local. When it works it’s clean and great. Feeling frustrated though.

I’m on a MacBook Pro w/Sierra, Local 2.0.4 with the Volumes add-on.

Here’s my log file:
local-by-flywheel.log (445.8 KB)


Hi @jivedig,

Sorry for the trouble!

If there are 500 errors, have you tried enable WP_DEBUG and/or checking the nginx and PHP error logs in the logs folder for that site?

[30-Jun-2017 14:56:49] NOTICE: fpm is running, pid 8
[30-Jun-2017 14:56:49] NOTICE: ready to handle connections
[30-Jun-2017 15:55:08] NOTICE: fpm is running, pid 29
[30-Jun-2017 15:55:08] NOTICE: ready to handle connections

error.log: (mostly calls to undefined functions cause the parent theme wasn’t there yet i think)
error.log (23.6 KB)

Interesting update: Restarted Local, it hung on startup for 10min, so I closed it. Launched it again, and for now the sites are all working. This will be the 3rd time going through stuff like this though, so I’m leery.

Is there a thorough way to completely remove and re-install Local, leaving no traces of Pressmatic or anything that may be causing issues?

FWIW: I have DesktopServer installed too, and still use it, though I always shut it down before launching Local.