Wp-config File Missing causing Unable to find DB_Host

What issue or error are you experiencing?

I am new to Local.
I have installed Local on Ubuntu.
I have successfully created the API credentials at WPEngine, I have even deleted the API credentials and created new credentials just to be sure.
I have successfully connected Local to the WPEngine account and I’m able to see the list of sites on the account from which I can pull environments.
I have attempted to pull 4 different environments from 4 different sites all resulting in the same issues. Here is my process and the results:

  1. I start Local

  2. I go to the “Connect” page and view the list of sites.

  3. I select “Pull to Local” button for one of the sites.

  4. I designate a name for the Local site and select the Environment to pull.

  5. I click “Connect & pull site”

  6. Local begins Provisioning the site.

  7. I am prompted by my system: “Authentication needed for ~/bin/bash as super user”.

  8. I successfully authenticate.

  9. Local appears to be downloading and extracting files as expected.

  10. When the process completes, Local displays an error at the top of the page: “Uh Oh! We ran into an issue when pulling from WP Engine”

  11. The Database tab in Local indicates that it was Unable to find DB_Host, Name, User, and Pass in wp-config.

    This is understandable because the wp-config.php file does not exist in the expected location: app/public/

  12. When I “Open Site”, the site opens in a browser, but it it is prompting me as if I am setting up a completely new installation of WP.

  13. I have attempted to set the database information to localhost, root, root, etc, but it just acts like brand new installation.

Any advice or direction would be greatly appreciated!

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

System Details

  • Local Version:
    Version 7.2.1+6433

  • Operating System (OS) and OS version:
    Ubuntu 22.04 LTS

Local Logs

Attach your Local Logs here
local-lightning.log (52.4 KB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @caustin

As a workaround are you able to download a backup from WPE and direct import that instead?

Hi @Nick-B
Thanks for the reply. Yes, as a workaround the direct import seems to have worked… (though out of 4 attempts, there was odd behaviour on 2 of them). Nonetheless, I was able to test what I needed to test.

While it is only marginally more cumbersome to import sites this way, having a fully functional, direct connection to WPE would be really great, especially as our client roster grows. Unless anyone else has any suggestions or thoughts regarding my original issue, I will wait until newer versions of Local are released and test that function on my system periodically.

Thanks again.

Certainly understand that Local Connect is an easier and smoother way to get your sites down. The direct import allows for a workaround when things aren’t working normally, but it also helps to tell us whether the issue is one with the site or with something in the connection.

In your Local Logs there are a lot of “SSH Key Permission Denied Errors”. I know you mentioned you tried resetting your API Credentials with WPE which is usually where we would have users start with that type of error. It could be worth doing a full reboot, and then a reset of the API credentials again to try and see if that helps refresh things:

Are you on an office network or using a VPN by chance?

@Nick-B , Thanks again. I’ll definitely try that!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.