WP Mail SMTP + Mailhog

with WP Mail SMTP installed to use Mailgun, but with Do Not Send checked, email still not arriving at Mailhog.

any way around that? apart from deactivating WP Mail SMTP (which does in fact help)

I am having this same issue. When WP Mail SMTP plugin is “active,” MailHog does not capture any emails. Emails are making it from local to the outside world, which is very problematic. Deactivating the plugin results in MailHog working properly again.

WP Mail SMTP has 3+ million users and in our experience is basically required to make email work in WordPress, so it would be nice if you could get MailHog to properly hog while this plugin is active.

The issue isn’t really so much a Local one as it is the way their plugin overrides WordPress functions. We always try and go above and beyond, but there is a limit to what we can solve for within Local. As Ben mentions in a thread below, “I’d reach out to their support and see if there are any settings or recommended workflows for using their plugin and working on a site that isn’t in production. You can’t be the only person that wants to use their plugin but also wants to do development on a site in a non-production environment.”

1 Like