Wpe ignore files not working as intended

What issue or error are you experiencing?

Since the 8.3.x update, the magicsync is no longer respecting the .wpe ignore files.

These are still wanting to push or be deleted when pulling as an example. Other ignores I have are uploads + plugins, which aren’t being respected.

I have already tried uninstalling and reinstalling, but this hasn’t worked either.

System Details

  • Local Version: 8.3.2

  • Operating System (OS) and OS version: Windows 10

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hey @dhudson – Welcome to the Local Community Forums!

Thanks for letting us know about this regression! I think we’ve zeroed in on when the bug was introduced and we have a rough fix in place, but if you are around, I’d love to see an example of your .wpe-*-ignore files so that I make sure I’m accounting for different exclusions.

You’re probably aware of this already but it’s also the case on MacOS. And on v8.3.1

Thank you @benrich! The team is aware and actively working on a fix for this issue.

After upgrading to version 8.3.1+6650, the site’s hidden push and pull ignore files are no longer being used. For instance, all node_modules directories are being ignored even though the -ignore files make no mention of this. Additionally I have custom rules to ignore the media directory which is no longer being respected.

System Details

macOS Sonoma 14.4

@ben.turner ,
I am having the same issue. I had upgraded to 8.3.1XXX and noticed this issue but didn’t see this ticket. This morning I saw a release for Version 8.3.2+6660, so I downloaded it and had the same problems. I wondered if maybe it wasn’t honoring the wildcards so I decided to manually add some in as well and it still doesn’t ignore the files. You can see in the screenshot, that it is trying to upload files that are in the ignore list.

Here is a copy of my push ignore file. You can see I have .prettier* in the file and I even added individual records for .prettierignore and .prettierrc just to make sure it wasn’t liking the * wildcard option.
.wpe-push-ignore.zip (1.4 KB)

Running macOS 14.2.1

1 Like

@ben.turner Do you happen to have a patched version we can try?

Hi @rbaugh! Just chiming in here while Ben is out. The team doesn’t have a Beta or anything ready with this for testing but they do have a ticket in and have been doing troubleshooting. We’ll keep you posted once we have some more details to provide! Thank you for your patience and communication with us here.

Version 9.0.1 beta includes a fix to use .wpe-push-ignore and .wpe-pull-ignore files again.

We generally release beta versions into production within a week or so.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.