WPE Multisite Import half working Local 5.2.5

I downloaded a zip backup from of a multisite (multilingual). Imported that into Local 5.2.5, which appeared to succeed.

The primary site works fully as expected frontend and dashboard
The backend is indeed multisite showing all the sub-sites, and the network dashboard.

Navigating to the backend of a sub-site fails. ERR_TOO_MANY_REDIRECTS
Navigating to the front end of a sub-site fails, the content is there, but no stylesheet or assets.

What’s odd is Local shows the site in as single site:

I tried resaving permalinks, and stop/starting the container.

Is MS still not working in Local 5 at all, or just not WPE imports?


Same thing, I exported a multisite from local 3.3x and imported in local 5.2.5 but it didn’t recognize it as a multisite.

I have the same problem. Imported multisite are forcibly added as single-site. I did an experiment. I created a test multisite in Local 5.2.5 exported it and imported back under a different name. The new site has become a single site.

Just had the same bug show it’s head here – imported a multisite from a ManageWP archive. Manually set the necessary multisite bits in wp-config.php, but Local doesn’t reconzize it as such and probably doesn’t load the relevant wordpress-multi.conf.hbs.

Where is «Multisite: yes» set? (I fear it’s somewhere in the bowels of some Localwp conf file).

Found it.
Added multiSite":“ms-subdir”**, to "iVZGyFuLM":{"id":"iVZGyFuLM","path":"/Users/me/Sites/mysite","localVersion":"5.10.5+5403","workspace":null,"multiSite":"ms-subdir","mysql":{"database":"local"... in ~/Library/Application Support/Local/sites.json

Then found ~/Library/Application Support/Local/run/iVZGyFuLM/conf/nginx/site.conf and changed include includes/wordpress-single.conf; to include includes/wordpress-multi.conf;
(possibly Local would have made that change itself on starting the site)

Voilà, WP Multisite imported from an archive.