404 Not Found nginx/1.16.0

Hello everyone,
I tried a few things i read about 404 topics, but nothing seemed to works. I tried to restart the computer. tested with new sites, switching the router mode on localmode…

If i try to create a new site, everytime i try to use the wp-admin or open site buttons, it keeps showing me the same page with the 404, nginx error.

If i want to import a website from WPEngine, it displays me on the local application “Uh-oh! We ran into an issue when pulling from WP Engine”. It seems i cant pull at all, see the screenshot below. And 404 error when i try to access it via the wp admin and open site buttons.

When creating a site using an .zip archive, i have some errors from mysql, and when i try to access the site, it still displays me a 404 anyway.

thanks for your time,
have a nice day

System Details:

Local Version: Local Version 8.2.0+6554

Operating System (OS) and OS version: Windows 10 19045.3930

Local Logs:
local-lightning.log (109.1 KB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @Nhercent

It looks like this error may be due to a special character in your Windows username.

Can you try creating and using a user directory without extended characters?


Hi Nick,
thanks for your reply. As i am working in a company that admins the windows users and all of the IT, networks and security, i unfortunately cannot edit the user. The windows username contains a $ and numbers.

Can you confirm that its the reason its not working, and is there another way around ?
Is this something that will be fixed soon ? As i read the topics it seems that its an incident going around for a few years now.

Thanks !

If you’re unable to edit the user I don’t know that there is another viable workaround. Do you have a different machine you could utilize? A personal machine or one with a different OS?

It seems part of the issue may lie with bugs that exist with WP-CLI which are a little bit more difficult to resolve or account for. I’m reaching out to the Dev team to discuss further options or alternatives but we don’t have any kind of ETA to provide on when this might be resolved.

I will try at home with another computer,
if it works then i’ll be sure its because of the user name. In the same time i will reach my company IT support to let them know about the issue, but i’m pretty sure they can’t do anything about the user name, as its the same pattern for every machine / employee user.

Thank you for your reply, I will let you know how it went, and if i find out a way to resolve this !

Sounds like a plan @Nhercent! If you have any other questions or concerns don’t hesitate to reach back out. :green_heart:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.