404 Site Not Found when trying to view site!

Hi just started to set my site up and i can’t view as it come up with : 404 Site Not Found

I have no idea what to do would appreciate the help it say first trying to get my head around and already hit a bump in the road!

did you ever get a resolution to your issue?

I have a similar issue. I think Local has somehow locked in settings for my WP Admin panel from two years ago, even though it was uninstalled since then. At the time I tried Local, I had been using WAMP server and Local completely screwed up all my work there in WAMP and I was not able to use any of it anymore. Is there a cache to clean out somewhere so that when I click on my admin panel from my existing host, I don’t go all the way back two years to my previous host’s login address for my WP admin panel?

Not been using LOCAL for long and am really only an amateur at WP.

I am having exactly the same issue, which only started a couple of days ago. At that point I had one imported site working (which still does!) and one default template I was working on. However, since then I have not been able to get any site (imported or new) to show up.

The “routers log” referred to has no entry since this one

2023/09/27 23:00:27 [error] 36520#33620: *5047 connect() failed (10061: No connection could be made because the target machine actively refused it) while connecting to upstream, client: ::1, server: nyas, request: "GET /wp-admin/themes.php HTTP/1.1", upstream: "", host: "nyas", referrer: "http://nyas/wp-admin/edit.php"

Hi @carl.waring

Are you on Windows? What version?

Do you have any antivirus, security, or firewall applications that could be blocking Local?

More details about troubleshooting this here: Router Mode

Are you running other developer applications simultaneously? That could also cause similar issues. Apps like MAMP, XAMPP, or Docker for example.

Yes, latest Win11.

Only the basic ones that come with the OS and they haven’t blocked it up to this point. (Will check though.)


The only recent change (ie between when it worked and now it doesn’t) is the recent version update to Win11 but I can’t see how that will have broken it; especially as an existing site still works.

But if you create a new blank site in Local that site runs into errors?

In order to refresh here and start with a clean slate could you give the below troubleshooting steps a try:

  • Export any sites that you have on Local and save them to a folder somewhere on your computer.

  • Fully uninstall Local from your computer.

  • Install the latest version of Local on this link.

  • Once installed, please restart the computer.

  • When the computer is restarted and turned on, close any applications that automatically run in the background (AntiVirus, Firewall, and other Developer applications included).

  • Check and see if the issue still persists. If so, please provide us with an updated log. Retrieving Local’s Log File

Keep us posted and we’d be happy to help further!

That did it!

(Well, I left the firewall running; mainly to see if it worked with it on or not. (If it hadn’t I would have turned it off and re-tested!)


1 Like

Glad to hear it @carl.waring! Happy Developing :slight_smile: