Local Community

Add back Sequel Pro support

As per discussion at Sequel Pro has been abandoned. New team has forked to Sequel Ace, support for Sequel Pro was recently removed under the somewhat false premise of Sequel Pro being an abandoned project.

However, on the referenced GitHub issue, the maintainer has clearly stated that the project is not dead: https://github.com/sequelpro/sequelpro/issues/3705#issuecomment-653258075

Yes, the last stable version of Sequel Pro doesn’t run smoothly on never computers, but the nightly builds are more up-to-date and work great. See https://sequelpro.com/test-builds

Personally, I use Sequel Pro on a daily basis, and removal of support for it without at least providing Sequel Ace as an alternative is super frustrating for me as a user.

1 Like

Hey @swissspidy, Welcome to the Local Community Forums!

Thanks for reaching out about Local and Sequel Pro, and I’m sorry that this has interrupted your workflow!

I’ve moved this topic to the “Local Add-ons” category to help focus the conversation on possible ways that this functionality can be returned!

Removing Sequel pro is part of a larger effort of the Local team to streamline and simplify the third-party tooling that we encourage users to use. This allows us to deliver a leaner, more stable core Local experience that can be extended by developers through the use of Add-ons.

Sequel Pro is unique in that it was included a long time ago, before a Local add-on was even an option. As the latest stable version of Sequel Pro (v1.1.2) was released in April of 2016 and has become broken for many users, the Local team has had to field many support questions around users being confused about why Local encourages the use of broken software.

As you mention, the nightly build of Sequel Pro does work, and the maintainer of Sequel Pro has said that they are working on the project.

At the end of the day, if having a one-click connection to a Local site in Sequel Pro interests you, I encourage you to explore creating an add-on!

In particular, the TablePlus addon seems to function in a similar manner to what you are trying to do with Sequel Pro, so you might consider reviewing that add-on’s repo:

Hope that helps give some larger context into our decision to remove Sequel Pro from Local. If you have any questions, just let us know how we can help!

If Sequel Pro is not the needed future-proofed solution, it would be great to get the get

  • «Sequel Ace» as quick-link replacement

  • or as a Addon like «Table Plus».

Alternative Woraround
Does anybody know a workaround or docs to connect a particular Local Database from Apps like Squel Pro/ Sequel Ace direct from the app direct.
So I could create for each of the local-db’s a connection-favorites. (not very user-friendly, but better than the cluttered interface and reduced options of Adminer)

Thank you

As of right now, Sequel Ace can only connect to a MySQL database over TCP/IP (ie, a networking port) and not over a Unix socket.

Windows machines already connect to the DB over TCP/IP because they don’t have unix sockets, but if you want to change a site under MacOS to use TCP/IP, then you can follow the steps outlined in this FAQ:

Once the site has been updated, then you can connect to that database in whatever way your SQL client uses to connect over TCP/IP

Hey Ben,
Thank you for your help and the link.

  • Should this also work with Sequel Pro out of the box? (I have never had any problems accessing Local DB’s with Sequel Pro in the past.)

Unfortunatelly Sequel Pro always throw an Mysql-Error: Unknown error 1045.

Have done Clay’s advice «step 1 & step 2».

Used Settings

  • Have I misunderstood something in Clay’s adviced steps?
  • Or does it not work with Sequel Pro as a connection-app?
  • Maybe only work with Sequel Ace?

I actually don’t know if this should work with Sequel Pro.

As far as I know, the stable version of Sequel Pro is broken. Some users indicate that the nightly version of Sequel Pro does work, however I’ve never used it, so I personally can’t verify this.

1 Like

You must use the Sequel Pro nightly.

Hey @anfragen,
Thanks for your hint.
Have downloaded Sequel Pro nightly.
Bildschirmfoto 2021-08-25 um 11.12.07

Unfortunately the Error is the same with the SP-Nightly-Built: reconnect with SiteShell. User was still created (error 1396) and the Port seams to be the same as last time 10033.

So I tried also the Sequel Ace App from AppStore:
Also with TCP/IP
Host: localhost
Username: root
Passwort:
Database: local
Port: 10033

Tried also check/uncheck Allow LOCAL-DATA-INFILE and Enable Cleartext plugin
in all possibilities (uncheck, uncheck | uncheck, check | …) allways the same error: 1045

What could throw this error?

  • Do I have to set some stuff different?
  • Any Idea?

Maybe I missunderstood some basic stuff …

You must use the socket to connect, not the port.

The socket will be shown in the Local site’s database tab.

Hey @afragen, thanks for your hint with the socket again:

I used in all 3 Apps the connection with socket: Copy/Paste from Databse-Tab.

Unfortunately the 3 trials also only ends in errors:
Tried with Sequel Pro, SP Nightly, and Sequel Ace…
PS: Also tried with Database: local
And checked/unchecked the 3 checkbox-options.


(Tried Sequel Ace also to connect with public remote server. NO Problem there, so the app should have the permissions from Mac OS ;o()

  • Any other idea, what I could make wrong so I only get an error on every App?

You must all ALL the data. You are missing the password and database name

1 Like

Hey @afragen
You are great! (I not so much)
I have set the DB as local by the try&errors, also the three checkboxes.

  • But Password I thought should be empty. (wrongheaded)

Now, with root for password all is working!

Insanely with the modernest App «Sequel Ace» I got still an connection-error with the totally-same credentials like in SP and SP Nightly: Can’t connect to local MySQL server through socket ‘/pathTo/Library/Application Support/Local/run/1KLWSRWOR/mysql/mysqld.sock’

But anyway, with:

  • Sequel Pro
  • Sequel Pro Nightly Built

all works and I can use the well-rehearsed Workflow.

Thank you for your patient

Sequel Ace is sandboxed for the Mac App Store and using sockets hasn’t quite been figured out yet.

Tried to find a solution with the «not sandboxed» Sequel Ace from Homebrew. But this throws same error. Seams to be a combination with your mentioned «hasn’t quite figured out yet» and the AppStore sandboxing.

Anyway: Sequel Pro & Sequel Pro Nightly works like a charme.
Hope for later, Sequel Ace will be fixed for the socket-problem and this will be a solution for replace the old «Sequel Pro» Shortlink in Local or maybe a solution with the Sequel Pro Nightly…

Thanks for help

@brandondove @aubreypwd any chance for building an add-on similar to the TablesPlus add-on?

Honestly, I tried. I actually created an issue about the sandboxing socket issue a little over a year ago (https://github.com/Sequel-Ace/Sequel-Ace/issues/108). Unfortunately, it doesn’t look like there’s a good path forward at this point. @afragen, if you have any ideas, I’d be happy to look into it.

1 Like

Actually Brandon I was simply thinking of bringing back support for Sequel Pro in this manner. The Sequel Pro nightly works fine with a socket.

1 Like

Sequel Ace has instructions of how to use sockets with the sandboxed version (it requires specifying the socket location) e.g. in my.cnf:

[mysqld]
 socket=/Users/YourUserName/Library/Containers/com.sequel-ace.sequel-ace/Data/mysql.sock

So it would be great to know how to over-ride the {{socket}} config to allow everything else to work properly.