Adminer Evo: localhost refused to connect on macOS

What issue or error are you experiencing?

The “Open AdminerEvo” button opens a browser window, but I get a ERR_CONNECTION_REFUSED notice: “localhost refused to connect.” The URL its trying to access is: http://localhost:10030/?username=root&db=local

The WordPress site works as expected, and I can access Mailpit on localhost without issue. Other projects (ex, React JS) work on localhost:3000 for example so I assume this is an issue specifically with AdminerEvo. The issue is the same in Chrome and Safari.


What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

I starting an existing site and tried to open AdminerEvo and got the the “localhost refused to connect.” error.

I stopped the site, and created a new site using these settings: PHP 8.3.0, MySQL 8.0.16, and nginix, and had the same issue connecting to AdminerEvo. So it seems to be an issue with LocalWP and not any individual site.

I have not tried downgrading Local or using older versions of MySQL yet.


System Details

  • Local Version: Version 9.0.4+6699

  • Operating System (OS) and OS version: macOS 11.7.10, MacBook Pro (Retina, 13-inch, Mid 2014).

This is an old laptop that I never use for development, so its possible there’s something missing or out of date that AdminerEvo is looking for. The WordPress sites work fine though, so MySQL seems to work ok.


Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)
local-logs.zip (32.1 KB)

I’m seeing notices like this, which seem relevant:

{"class":"Process","level":"verbose","message":"Spawned","pid":2999,"process":"php-adminer","thread":"main","timestamp":"2024-06-30T01:10:36.157Z"}
{"class":"Process","code":null,"level":"verbose","message":"PID: 2999 closed with","process":"php-adminer","signal":"SIGABRT","thread":"main","timestamp":"2024-06-30T01:10:36.315Z"}
{"class":"Process","level":"verbose","message":"Spawned","pid":3001,"process":"php-adminer","thread":"main","timestamp":"2024-06-30T01:10:36.902Z"}
{"class":"Process","code":null,"level":"verbose","message":"PID: 3001 closed with","process":"php-adminer","signal":"SIGABRT","thread":"main","timestamp":"2024-06-30T01:10:37.279Z"}
{"class":"Process","level":"verbose","message":"Spawned","pid":3004,"process":"php-adminer","thread":"main","timestamp":"2024-06-30T01:10:37.782Z"}
{"class":"Process","code":null,"level":"verbose","message":"PID: 3004 closed with","process":"php-adminer","signal":"SIGABRT","thread":"main","timestamp":"2024-06-30T01:10:37.812Z"}
{"class":"Process","level":"verbose","message":"Spawned","pid":3006,"process":"php-adminer","thread":"main","timestamp":"2024-06-30T01:10:38.318Z"}
{"class":"Process","code":null,"level":"verbose","message":"PID: 3006 closed with","process":"php-adminer","signal":"SIGABRT","thread":"main","timestamp":"2024-06-30T01:10:38.361Z"}

I also found this forum topic ERR_CONNECTION_REFUSED while opening Adminer on Linux - #6 by ben.turner where there was an issue in Linux that might be similar, but was patched in 2022.


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

I think that the SIGABRT signal means that something is crashing PHP itself, which would be why AdminerEvo isn’t working.

You mention trying this with PHP 8.3 – do you get the same experience for sites using 8.1 or 8.2?

Yes, I created a new site using PHP 8.1 and got the same result. The site works fine, but I can’t access AdminerEvo and I get the same error message:

{"class":"Process","level":"verbose","message":"Spawned","pid":6232,"process":"php-adminer","thread":"main","timestamp":"2024-07-07T19:58:50.382Z"}
{"class":"Process","code":null,"level":"verbose","message":"PID: 6232 closed with","process":"php-adminer","signal":"SIGABRT","thread":"main","timestamp":"2024-07-07T19:58:52.356Z"}
{"class":"Process","level":"verbose","message":"Spawned","pid":6240,"process":"php-adminer","thread":"main","timestamp":"2024-07-07T19:58:52.858Z"}
{"class":"Process","code":null,"level":"verbose","message":"PID: 6240 closed with","process":"php-adminer","signal":"SIGABRT","thread":"main","timestamp":"2024-07-07T19:58:52.878Z"}
{"class":"Process","level":"verbose","message":"Spawned","pid":6241,"process":"php-adminer","thread":"main","timestamp":"2024-07-07T19:58:53.383Z"}
{"class":"Process","code":null,"level":"verbose","message":"PID: 6241 closed with","process":"php-adminer","signal":"SIGABRT","thread":"main","timestamp":"2024-07-07T19:58:53.410Z"}
{"class":"Process","level":"verbose","message":"Spawned","pid":6242,"process":"php-adminer","thread":"main","timestamp":"2024-07-07T19:58:53.918Z"}
{"class":"Process","code":null,"level":"verbose","message":"PID: 6242 closed with","process":"php-adminer","signal":"SIGABRT","thread":"main","timestamp":"2024-07-07T19:58:53.937Z"}

It looks like the process keeps trying to start and being aborted.

Again, I assume the problem is related to this being an old laptop I never use for dev work. I checked the requirements to run Local and I should be good. If there’s a list of cli commands you want me to run to make sure xcode or brew or whatever has the correct packages installed, maybe that would help? Idk.

Those requirements are a good starting point, and offer baseline for the main Local app. In the past, we haven’t ever marked the various lightning services (in this case, Adminer Evo) as having a minimum requirement, but it is looking like Adminer Evo isn’t compatible with MacOS Big Sur. Since MacOS now has Sonoma, and typically they only provide security updates for the last two releases of MacOS, I think the best option would be to upgrade to a newer OS.

That being said, if you can’t upgrade MacOS, you probably have two general ways you can proceed (though I’m not 100% sure the first one will work):

  • Download an older version of Local to make use of the older “Adminer” utility. It looks like Adminer Evo was release in the 8.2.1 version of Local, so you’ll want to install at least 8.2.0 or earlier. I’m not sure this will work, but maybe!
  • Continue using the latest version of Local, but instead of using Adminer Evo, you can use a different DB client. I’ve liked TablePlus and Local has an addon to add a one-click button to open the site’s db in TablePlus. But there are lots of different DB clients you could use. This option might be the next-best option after upgrading MacOS because at least you’ll be using the latest version of Local.