Local Community

Adminer not working with 'refused to connect' error on ubuntu 20.04

Issue Summary

One or two sentence summary of the issue.

Can not access database through adminer.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?


Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

Install local-6.1.0-linux.deb to Ubuntu 20.04
Try to access “adminer”

System Details

  • Which version of Local is being used?

I am using local-6.1.0-linux.deb

  • What Operating System (OS) and OS version is being used?
    • For example: macOS Catalina or Windows 10 Professional

I am using Ubuntu 20.04

Tried to fix the issue following these steps Accessing database Issues however, none of the steps help.

It has been 20 hours with no reply.
Should we consider this app as not supported and dump usage?

It is strange, that once I register I get a rep call (three times already) about services and so on. How come support forum is so dead?

Hey @eimantas, Welcome to the Local Community Forums and I’m sorry you haven’t had a reply within a timeframe that you were expecting! We’re always looking for active community members to help with these kinds of requests, so maybe that’s something you’d like to help with! :smiley:

Taking a look at your Local Log, I’m seeing an error like this:

{"thread":"main","class":"HostsFileService","error":{"killed":false,"code":126,"signal":null,"cmd":"cd \"/home/dev\"; export ELECTRON_RUN_AS_NODE=\"1\"; \"/usr/bin/pkexec\" --disable-internal-agent /bin/bash -c \"echo SUDOPROMPT; export ELECTRON_RUN_AS_NODE=\\\"1\\\";/opt/Local/local %%appPath%%/main/dns/workers/updateHostsFileWorker.js babor.local www.babor.local\""},"stdout":"","stderr":"Error executing command as another user: Request dismissed\n","exitCode":126,"level":"error","message":"Could not update hosts.","timestamp":"2021-08-03T09:09:03.158Z"}

That part of the error that looks like this: Error executing command as another user: Request dismissed means that for whatever reason, your computer’s user didn’t give Local the permission it needs to update the Hosts file. Given that Adminer is running on localhost, I don’t think that this would be a problem, but it hints at the fact that maybe a firewall or other security setting is in place and preventing the browser from accessing Adminer.

I’d recommend taking a closer look at any security settings for the computer and see if that port is being actively blocked.

I have given now the correct permissions for ‘local’ to edit the hosts file. It does edit it now, however, I am still unable to use adminer or find database anyother way.
I am attaching local-lightning.log file. local-lightning.log (218.3 KB)
Any idea how can I fix this?

That’s great that the hosts file can be edited by Local now and thanks for that Local log!

When I reviewed the Local log, I’m not seeing anything specific related to why adminer wouldn’t be working.

When I took a closer look at that screenshot of the browser, it looks like it’s trying to access port 10000 on localhost.

That doesn’t seem right to me. Usually when you click the “Adminer” button, a new PHP process is spawned and is listening on a new port that’s oftentimes higher up.

Can you try a few other troubleshooting steps?

  1. Create a new site

  2. Click the “Adminer” button for that site

  3. If you still get the connection refused error in the browser, open a terminal and run this command to see if any of those php processes actually exist:

    lsof -i -P -n | grep php

Can you share what the output of that command is? If you do get some output from that command, you might also try accessing that port in a browser. Here’s a screenshot to help visualize the url to use:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.