Problem with open Adminer and install addons

Issue Summary

Adminer’s page (http://localhost:10030/?Username=root&db=local) is not responding.

This site cannot be reached. The localhost server has refused to connect.
Try these solutions:
Check the connection
Check the proxy server and firewall

I tried reinstalling Flywheel Local - no effect.
Before that, I had a problem with local domains. I changed the Apache port in ubuntu to 8080 to avoid conflict and work on my own domains.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?

All sites

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?
    Yes, ki have acces to all sites, but i cant open adminer panel.


Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

  1. Create New Project
  2. Click ‘OPEN ADMINER’ in Database tab

All sites works fine, only adminer page not respond.

System Details

  • Which version of Local is being used?

  • What Operating System (OS) and OS version is being used?
    Ubuntu 20.04

  • Attach the Local Log. See this Community Forum post for instructions on how to do so:
    local-lightning.log (253.0 KB)

I have the same problem
It’s a today freshly installed Local today.

I’m on Ubuntu 21.04
local-lightning.log (6.7 KB)

The site works, adminer does not.

I spent some time trying to replicate this on my Ubuntu 21.04 machine and haven’t been able to do so.

Since you are able to access the site front-ends, but not adminer, that makes me wonder if there’s something happening when Local tries to set adminer to listen on a specific port.

Does a restart of the computer help at all? I’m wondering if restarting helps to clear out any orphaned processes that might be occupying ports.

Same problem here on Ubuntu 21.04.

Very frustrating not to be able to get to Adminer.

Looks like the workaround is to use php 7.3 instead of php 7.4. This was discovered in ERR_CONNECTION_REFUSED while opening Adminer on Linux (Pop OS)

Someone else suggests installing the WP phpMyAdmin plugin: Adminer Not Working

I am having the same problem:

My local environment:

computer: Lenovo laptop
os: Pop!_OS 21.04

I created my localWP instance with:

server: apache
php: 8
db: mysql 8.0.16

Here are urls generated by ‘Local’:
wp site: http://localhost:10009/ — working
adminer: http://localhost:10010/?username=root&db=local — not working

After it was created I clicked ‘trust’ next to the ‘SSL’ field on the overview tab. The ‘Web Server’ field was populated with ‘nginx’ even though
I spec’d ‘apache’ on setup so I changed it back to ‘apache’.

Opening the site worked fine but when clicking the ‘Open Adminer’ button
on the ‘Database’ tab I am given an error message by Brave & Chrome browser:

"This site can't be reached

Checking the connection
Checking the proxy and the firewall
  • I am not connected via proxy

I changed the ‘router mode’ to ‘localhost’ and ‘Local’ warned me ‘This site’s WordPress URL settings do not match the host set in Local’ so I clicked ‘Fix It’. Opening the site works fine but trying to access ‘Adminer’ produces the same error messages on both browsers.

I checked to see if an instance of Apache running on this machine may be blocking port 80 but this did nothing to help access ‘Adminer’.

The last thing I tried was disabling any conflicting instances of Apache already running/listening on my machine via terminal command:
sudo systemctl disable apache2

  • EDIT
    Using a CLI utility called nettools I went looking for other processes running on port 80 per the instructions on the ‘Router FAQ’ with and without Local running.
  • Local NOT running: nettools showed no processes listening on port 80.
  • Local RUNNING: nettools returned a process with PID 45562 called nginx:master.

Below is the full line returned by nettools:
tcp6 0 0 :::80 :::* LISTEN 45562/nginx: master
– The strange thing about this to me is that my project is setup to run on Apache. Maybe nginx is used by local to serve as the ‘router’ described in the faq?

If anyone can give me some pointers on how to diagnose/fix this issue it would be greatly appreciated!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.