After updating, I get an error about not being able to establish a connection with

I’m not good at English, so I use a translation app. I’m sorry if I wrote a strange sentence.

The OS I’m using is Windows 10.
Today, when I started Local, I was just notified about the update, so I updated to 5.3.1.
Successfully updated, I have created a new site. There was no problem so far.

I’m Japanese, so when I tried to set the language from the admin screen of the new site, I got the following error: wordPress could not establish a secure connection to Please contact your server administrator.

Not only that.
I couldn’t do anything when I added a new plugin from the admin screen with the same error.

Other sites I’ve already created in Local are getting the same error. Therefore, even if you do blue print, a site with an error will be created.

I also tried manually updating to 5.4.2 but that didn’t resolve the issue.

For now, this error doesn’t seem to cause any of the following issues: The site won’t open, posts or themes cannot be edited, etc.

Is anyone suffering from the same phenomenon?
Also, does anyone know a solution?

Hi @yshimizu,

Welcome to the Local community!

Does this issue persist after restarting your PC?

Also, another thing to check is that your firewall is not blocking Local’s PHP process.

Thanks for the reply, @clay

I restarted the PC but the problem persists.
We are confirming the firewall, but it seems that it will take time because it is managed by the security software used instead of the default function of Windows.

While researching, I noticed one thing.
When I started Local, I found that nginx was working in Task Manager so far, but now it doesn’t seem to be working.

I’m unfamiliar, but I will continue to investigate and confirm.

Sorry for the series of posts.
I just report that the issue has been resolved!

It appears that the security software I am using without my knowledge has removed the Local PHP process from the allowed list.

I reported that nginx doesn’t seem to be working, but after writing it started working.

I will check the firewall settings just in case I update Local in the future.

Now I’m ready to work with Local again.
Thanks for the nice application and support!

1 Like

Wonderful! Thanks for sharing the solution :slight_smile:

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.