Any ".dev" Domain Is Not Working

What issue or error are you experiencing?

I cannot change a site’s domain to a .dev domain: the browser won’t accept its certificate. On Chrome it says NET::ERR_CERT_AUTHORITY_INVALID, and that it uses “HSTS”. On LocalWP, a popup appears stating “Heads-up! We run into an issue trusting the SSL Certificate” when i try to “trust” the SSL certificate, preventing me from creating a certificate…
I don’t know seems like .dev is not supported :thinking:


What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

change a site to a .dev domain


Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)
{“database”:“local”,“password”:“[REDACTED]”,“user”:“root”},“name”:“prova”,“oneClickAdminDisplayName”:“a”,“oneClickAdminID”:“1”,“path”:“~/Local Sites/prova”,“ports”:{},“services”:{“mailhog”:{“name”:“mailhog”,“ports”:{“SMTP”:[10001],“WEB”:[10000]},“type”:“lightning”,“version”:“1.0.0”},“mysql”:{“name”:“mysql”,“ports”:{“MYSQL”:[10004]},“role”:“db”,“type”:“lightning”,“version”:“8.0.16”},“nginx”:{“name”:“nginx”,“ports”:{“HTTP”:[10003]},“role”:“http”,“type”:“lightning”,“version”:“1.16.0”},“php”:{“name”:“php”,“ports”:{“cgi”:[10002]},“role”:“php”,“type”:“lightning”,“version”:“8.1.23”}},“workspace”:null,“xdebugEnabled”:false}},“thread”:“main”,“timestamp”:“2024-01-11T00:04:51.273Z”}
{“class”:“HostsFileService”,“level”:“debug”,“message”:“Updating hosts”,“thread”:“main”,“timestamp”:“2024-01-11T00:04:51.273Z”}
{“class”:“HostsFileService”,“level”:“info”,“message”:“Updating hosts with”,“thread”:“main”,“timestamp”:“2024-01-11T00:04:51.274Z”}
{“class”:“HostsFileService”,“level”:“debug”,“message”:“Updating hosts with command”,“thread”:“main”,“timestamp”:“2024-01-11T00:04:51.275Z”,“updateCommand”:“/Applications/Local.app/Contents/MacOS/Local”,“updateCommandArgs”:[“%%appPath%%/main/dns/workers/updateHostsFileWorker.js”,“ytuyyutuy.devi”,“www.ytuyyutuy.devi”]}
{“class”:“Process”,“level”:“info”,“message”:“Killing process”,“pid”:19760,“process”:“nginx”,“thread”:“main”,“timestamp”:“2024-01-11T00:04:53.265Z”}
{“class”:“Process”,“code”:0,“level”:“verbose”,“message”:“PID: 19760 closed with”,“process”:“nginx”,“signal”:null,“thread”:“main”,“timestamp”:“2024-01-11T00:04:53.280Z”}
{“class”:“Process”,“level”:“verbose”,“message”:“Spawned”,“pid”:19795,“process”:“nginx”,“thread”:“main”,“timestamp”:“2024-01-11T00:04:53.283Z”}
{“class”:“HostsFileService”,“level”:“info”,“message”:“Updated hosts.”,“stderr”:“”,“stdout”:“Updating hosts file at /etc/hosts\nUpdated hosts file at /etc/hosts\n”,“thread”:“main”,“timestamp”:“2024-01-11T00:04:57.581Z”}
{“level”:“debug”,“message”:“Database responded to ping.”,“service”:{},“serviceBinVersion”:{},“thread”:“main”,“timestamp”:“2024-01-11T00:05:01.814Z”}


UPDATE: there was a bug preventing me from "Trust"ing the certificate, in LocalWP/Overview/SSL.
Just switch-off LocalWP and then switch it on .
Following this simple guide made it work SSL Certificate on macOS - Local

Hi @kraken97 - That’s correct. We have a banner that will pop up in the app as sort of a warning.

There are some older threads here that go into more detail, but this was a factor in why we landed on .local as our TLD.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.