Big Sur & Trust Issues

Is this issue a problem for anyone using BigSur or newer?

I could swear this issue got resolved but here I am still dealing with this on new sites.

MacOS = Ventura

@arecian yes this is still any issue.

Thanks, ugh. I’m not seeing it on every new site I create which is why I thought it was fixed.

How annoying.

@arecian and @matthewfarlymn

So this isn’t happening on every new site you create? Are they any consistent steps to replicate or is it just random?

That’s hard for me to say. I don’t create new sites often. So when it was working, it was likely one of the Local versions before the current one.

With the current one, I tried one with default setup options and one with custom, both did not work.

Hi @arecian

It sounds like you’re still just running into the expected behavior per our help doc details that you linked above.

MacOS BigSur doesn’t allow Local to automatically trust an SSL certificate.

Right now, the only way for BigSur users to work with a Local site over HTTPS is to manually trust the SSL certificate following the steps below.

We know this is annoying and are exploring alternative ways that Local can make this process easier.

Yeah I get that now… someone answered that for me above already that this is still an ongoing issue. The reason I asked is that it was working for me a version or two ago and I’ve been on Big Sur or above the whole time.

It seems crazy to me that BigSur was released in 2020 and this is still an issue.

Hi @arecian

We have made steps to try and improve on this (as noted at the bottom of the doc above), but some users still run into issues intermittently. What specific error are you seeing in your browser? Does anything show up in the console? Feel free to share screenshots.

Hi @Nick-B,

UPDATE

I’ve attempted to follow the steps again in the article +.

  1. Quit local
  2. Delete certs folder
  3. Delete all .local certificates from keychain
  4. Start local
  5. Trust site (same error appeares and the keychain certificate is not trusted)

To confirm I have followed the steps at the end of that document and it never resolved any issues. Even when creating a new test site.

I’m running macOs Ventura and constantly received the following error even after completely deleting the certs folder. The only solution has been to manually trust the certificates in keychain.

Thank you for sharing those details @matthewfarlymn!

For @arecian - Have you run through the same steps and found they haven’t worked as well? Just curious what you’ve tried or since the issue has been intermittent if you’ve just left it as is.

I have. Same result as @matthewfarlymn. The most recent site was created in Local 6.7 and still the same.

Hey all, just chiming in here - a more accurate description on that help doc would be “Big Sur and beyond”. It isn’t a “bug”, but rather a macOS change that requires users to enter Keychain and “Always Trust” the certificate Local creates.

The fix we’ve landed on is to change our approach to SSL entirely; rather than site-specific certs that users trust 1 by 1, our plan is to move to a global certificate that a user trusts once, and then each site can rely on that certificate. This should remove many of the potential pitfalls we see with SSL - and simplify the Local code too :slight_smile:

No ETA to share immediately (our focus is on PHP 8.2 support first!), but it is on the near-term roadmap.

3 Likes

So you’re saying we’d only have to do this keychain process once and then not again for each site?

That sounds great provided there’s not any unintended consequences of going the global certificate route.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.