Local on Apple Silicon Macs - SSL not trusting

Issue Summary

So I installed a Local on mu new Macbook Pro with Apple silicon. All seems to be working well except that I am unable to trust the SSL sertificate. After I click on “trust” link and enter my password the popup window disappears but the sertificate is not installed. I have already tried it at least 10 times.

Troubleshooting Questions

- Does this happen for all sites in Local, or just one in particular? - I have tried to install 4 sites and it happens with all of them. One of them I managed to get “trusted” after 4 times of adding my password.

- Are you able to create a new, plain WordPress site in Local and access it in a Browser? - Yes


Create a new site with Aplle Silicon based Macbook and try to verify the SSL certificate.

System Details

- Which version of Local is being used? - Latest, downloaded today

- What Operating System (OS) and OS version is being used? - Big Sur

Have you tried this?

1 Like

Thanks, this workaround works although I think Local team should take a closer to fix this issue.

Hey there

If you don’t mind me asking - how are you finding working with the new macs? I’m a developer and want to get one but wondering if it will work ok with apps I use - Photoshop, Sublime Text, Local, Codekit, FTP applications etc

Have you run into many problems generally?


I bought a new M1 silicon 8gb Macbook Pro and it is awesome. So far:

  1. Local has issues with SSL as I described
  2. Photoshop 2021 beta works well and fast
  3. Final cut is really fast
  4. Forklift is my main FTP cliend and works without any issues
  5. i use Atom for coding and haven’t notice any issues

I have had it for the 2 days and only issues I have noticed is the Local SSL one. Otherwise the Rosetta 2 emulator is really good. For example, Luminar photo editing app is sometimes slow and sluggishin my 16gb iMac but wit M1 it’s like another app - so fast, and the app isn’t even optimized yet.

So yeah, I’m really happyso far

PS! And the battery life is especially awesome. Oh, and the laptop is so silent…


Amazing - really appreciate the feedback, thats reassuring. I might get one. Thanks dude :slight_smile:


I set it like this: CleanShot 2020-11-22 at 22.00.43.png - Droplr but Chrome still shows “Not Secure” to the left of the local site URL in the address bar.

Mind sharing how you fixed it?

Never mind. Restarted Local and the computer and it’s working fine now.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.