Upgraded to 2.1.1 Now can't create new site that works

This morning I upgraded Local by Flywheel to 2.1.1. and then attempted to create a new site, for which I got a 500 Internal Server Error.

I have spent the last couple of hours deleting and creating sites, encountering a variety of errors along the way. I’ve reset the Virtual Box Machine. I’ve restarted my Mac and Local a number of times. I’ve created a new site from a Blueprint (which gives me the 500 Internal Server Error or the etc/hosts error or Local Router Error). I’ve created a new site without a Blueprint, which gives me Error! WordPress installation failed.

While stopping the latest site I get the following alert: “Uh-oh! Local ran into an issue while dumping carolros’s database to the site’s “app/sql” directory. Please check the local-by-flywheel.log file for more details.”

Since the former .dev domain seems to default to .local, I have tried both.

I tried viewing one of my existing Local sites and it seems fine.


This text will be hidden

Hi Lisa,

Sorry for the trouble!

I’m not able to reproduce the 500 error. What environment settings are you using for the new sites?

Also, regarding the WP installation error, please upgrade to Local 2.1.2 and it’ll fix that issue.

I just tried creating a site from a saved Blueprint and it doesn’t work because I too am getting the 500 Internal Error.
This really sucks when you get up early and ready to work on a web project. I didn’t have these issues back with the older version that used .dev. Im on WINDOWS 10, and the site is WP 4.9, Custom 1.2, PHP 7.1.4 Apache, MySQL 5.6.34

I just noticed I am on 2.1.1 and that there is an updated version. How do we update? There’s no button to check for updates in LOCAL…it would be a really nice feature to have some way of knowing WHICH VERSION of LOCAL is currently installed.


UPDATE: Even after updating to 2.1.2, I STILL get 500 Internal Server Error. :frowning:

I needed to start this project so my workaround was to CLONE the site from which the blueprint was created. This worked. However I doubt this is ideal - first of all, it takes FOREVER to create since it has to replace all instances of the previous domain used. Creating a site from a blueprint doesnt work for me and it would be great to get some solution here. SIDE NOTE: Even using the CLONE method I got the Uh Oh message shown in the screenshot. I then had an orange bar the top where I had to click to fix missing hosts entry.

I have now uninstalled Local 2.1.2 AND uninstalled VirtualBox 5.1.30 and restarted computer and reinstalled everything and I still CANNOT create a website from blueprint. Here is the log file:local-by-flywheel.log (601.6 KB)

I am able to recreate 2 sites that I had based the blueprints on, and those work. But I cannot create new sites using those blueprints. Does this help for troubleshooting?

UNEXPLICABLE BREAKTHRU: Switching my web server from Apache to nginx seems to resolve the issue for the new sites I am creating but would lead to 500 Internal Server Error.

I used to be able to use Apache server… is this a bug??

1 Like

Hi @metrosuperstar,

There’s currently an issue with the .htaccess file when importing sites with Apache or using Blueprints with Apache. The fix will be released in 2.2.1.

If you do run into the issue, simply browse to the .htaccess file in app/public and delete it. Then, go to Settings » Permalinks in WordPress and click save. This should regenerate the .htaccess file.

Sorry for the trouble!

Hi, thanks for your reply. Do you know when It’ll be released?

I found a temporary solution, instead of a blueprint, use an actual WordPress installation with all you need for any project, then duplicate it. Done!