Local Community

'Admin' and 'Open Site' buttons broken (again) after update

Bug Summary

Following update to Local 6.3.0 on macOS 12.0.1, both site access buttons do nothing.

Steps to reproduce

  • Open Local
  • Start any site
  • Attempt to visit frontend or admin with either button

Console log shows:
Error: Invalid package /Local.app/Contents/Resources/app.asar

Local log shows an unhandled rejection on every button event:
{“thread”:“main”,“reason”:{},“p”:{},“eventId”:“3c6b74defdf64b678b4235886e1328a6”,“level”:“warn”,“message”:“Unhandled Rejection.”,“timestamp”:“2022-02-28T11:21:57.364Z”}

Looks like that Electron upgrade isn’t as shiny as it looked …

Environment Info

Describe your environment.

  • What Operating System are you using?
    macOS 12.0.1

  • What versions of site software (Nginx, Apache, PHP, MySQL) is used?
    Irrelevant/all

  • What version of Local is installed?
    6.3.0 (5756)

Supporting info

Please provide your Local Log. See this Community Forum post for instructions on how to do so:
local-lightning.log (15.8 KB)

Include any screenshots or video recordings of the issue to help others reproduce.

Hi @logicelf - this issue has been noted and solved in another thread. Please set a Default Browser in Local’s preferences. This issue will be resolved in the next release of Local, hopefully later this week.

That works - thanks very much (that was becoming very tedious). :slight_smile:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.