Briefly unavailable for scheduled maintenance. Check back in a minute

So, first I try to update plugins and after a long time it returns a local router error message…then I restart local machine and then I get Briefly unavailable for scheduled maintenance. Check back in a minute. and it’s been so since preventing me from working,…what’s wrong here?

Hi, Local, this really sucks…after failed attempt to install updates then it deletes plugin from admin…look at the screenshots…what’s really happening with Local?


Are you on macOS or Windows?

Also, there may be a .maintenance file stuck in the WordPress root from the failed upgrade. You can remove that file.

I’m on macOS (and on the High Sierra update if that means anything).

Meantime, where’s this .maintenace file you mean? I don’t see it. And is that the problem? Might there be another causing it?

I’m on macOS (and on the High Sierra update if that means anything).

The .maintenance file is hidden by default.

You can delete the file using Terminal. Here’s how:

  1. Open Terminal
  2. Change to the Local site’s app/public directory. Type cd and then drag the public directory from Finder into the Terminal window. It should look something like cd ~/Local\ Sites/LOCAL-SITE/app/public
  3. Run rm .maintenance
  4. Check the site
1 Like

Can I do this without terminal? I’m having the same issue, but I’m not familiar with using terminal. I tried copying the text above but I get: -bash: cd: /Users/Carolyn/Local Sites/LOCAL-SITE/app/public: No such file or directory

I have figured out how to view hidden files, but I don’t know where to look for .maintenance. The search bar doesn’t find it.

I’m using Yosemite.

Hi @purplepyro,

Please see the GIF below (you may need to click on it so it’s not blurry):


In MacOS Sierra and above, you can show hidden files with a keyboard shortcut:

Cmd + Shift + .

I hope this helps.



I am locked on the maintenance mode, though the .maintenance does not exist. I have attempted via Terminal and via revealing hidden files on OS X (High Sierra).

Luckily, I use Git, so I was able to utilise version control to remove my changes and escape maintenance mode.

That said - this means I cannot update plugins because of this risk.

Please fix!


Hi @elliottmangham,

Glad you got it sorted.

What Environment is the site running? Preferred or Custom?

Thank You! this worked Great!

Hi, I’ve had this problem several times after I create a new Wordpress site. I found an easy way to remove the maintenance file if you are on a Mac.

1.) go to site’s yoursite/app/public/
2.) click: command - shift - .
3.) this hidden file: .maintenance will appear
4.) click on it, put in trash
5.) refresh page

This works for me every time.

1 Like

Thanks, this is exactly what was tripping me up!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.