Can not configure Local to work with uploads directory that is symlinked to an external harddrive

I am trying to get the uploads directory working as a symlink to an external harddrive that has all of the images in the wp-content/uploads directory that I need to symlink to from within local. When going to the Local sites, I create a symlink and chmod it 777, while the permissions are fine, the images do not show at all on the Local By Flywheel site.

So, in the Local Sites/project/app/public/wp-content directory I do the following:

ln -sf path/to/external/hardrive/uploads uploads

The symlink gets created and even chmod it to 777, and the permissions on it seem fine and the user and group are also fine, but the images just do not show as if the uploads directory didn’t even exist at all.

How to get images loaded that are from an external harddrive that I just don’t have the space on my computer to keep 11 gigabytes of images on.


You must use the Local Volumes Add-on.

Hello afragen, this addon does not work as it only allows the Host Source to be coming from your own computers harddrive and must exist in the “Users” directory. So, thanks, but I have already tried this addon to attempt to try this, and it was unsuccessful as I can not logically store 11 gigs of images on my harddrive and must come from the external harddrive instead, which is outside of the “Users” directory of the current harddrive.

You might need to play within the limitations of the Volumes add on. Using symlinks inside a virtual machine doesn’t work. You neee to create a synced folder. This is what the add on does.

You might try putting a symlink into you user directory so that the Volumes add on sees it.

You should also search the forums for use with Dropbox.

Hello afragen again, I’ve tried symlinks within the Users path also, no go, it points to the root path (that is located on an external drive) and does not allow it in the Volumes addon. Dropbox again is not gonna work because this will use up the actual space on your computer that does not have the 11 gigs of space in the first place to dedicate for these files. Thanks for your attempts to help here, but they would not work if you tried this yourself. I think it’s because of the VirtualBox that is being used here, this makes it NOT possible.