Cannot change from nginx to apache on Mac

Hi, I had to look for the solution myself and spent many many hours trying to solve this issue. I even posted the issue on Youtube without getting a reply from the Youtube community who were heavily promoting it.

I know you are supposed to be able to export an nginx server site and reimport it into a new site as Apache server, and but on a Mac I cannot set the server type in Custom Environment to Apache and cannot switch to Apache. I know your forum says it can be done, but nginx is selected and greyed out. I tried it on multiple Macs and versions of OS X. Presently I run Catalina 10.15.5, but it did the same on 10.15.4. and 10.14.x

I have set custom environment as preferred, and exported and reimported many times, but nowhere does it give me the option to choose the server type.

Has anyone actually switched successfully on a Mac? If so, please share the exact procedure.

You must set the environment to ‘Custom’ when creating the site. Setting the site as ‘Preferred’ fixes the web server, php version, and database.

Hi @ts971,

Switching web servers is only available in Local 5.5 and newer. You can download Local 5.5.3 here: Local 5.5.3

We’re looking at releasing Local 5.5 to the auto-updater sometime this week.

Hi @clay

Thanks for acknowledging what I have been saying was the case or months, and everyone kept giving me this nonsensical solution. I will try it now.


Thanks to @clay and the team. 5.5.3 on Mac works fine. There is a tiny bug when you set SSL. When you apply, nothing changes until you to tab away and then tab back on SSL and the status displays TRUSTED.

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.