Can't reach site with ERR_CONNECTION_RESET error

Issue Summary

.crt file is trusted but HTTPS still doesn’t work.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    All sites

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?
    I can access a new, plain WordPress site but can not enable SSL on it.


Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

Not sure how to replicate this, It isn’t occuring on any of my friends local sites

System Details

  • Which version of Local is being used?

  • What Operating System (OS) and OS version is being used?
    macOS Big Sur

  • Attach the Local Log. See this Community Forum post for instructions on how to do so:
    local-lightning.log (10.0 KB)

Hi there, I’m wondering if you’re using a VPN, Proxy or Firewall?

1 Like

Hi Yarfi,

I’m not using a VPN or a Proxy. Also, I just checked and my firewall is off.

Any idea what might be causing the issue?

Hey @jlsmith497

Was the site working over regular HTTP before trusting the SSL certificate?

Looking at the specific error on the browser window, it looks like the message is ERR_CONNECTION_RESET

I’ve seen this a few times in the past, and it’s a really hard thing to zero in on.

The ERR_CONNECTION_RESET error is really hard to diagnose because it’s so generic of an error.

This help doc is focused on Windows, but does a good job of outlining the problem and gives some good ideas for what might be going on.

A few things I would recommend trying:

  • Does the site load in a different browser? If it does, there’s likely something cached within the original browser that’s causing issues.

  • How are you connected to the internet? You mention there isn’t a VPN or Proxy and the firewall is off. Do you have any custom DNS resolver for the LAN?

  • As a test, can you try a different local domain? So for example, if you pull a site down that’s been using my-localsite.local can you try pulling to a site that has a randomized url like my-localsite-xyzabc.local.

  • Examine any antivirus or security settings and possibly disable them temporarily. It might be that the browser has been able to “find” the Local site, but something like a firewall is preventing the browser from actually “connecting.”

Hi Ben,

Thanks for the help, really appreciate it!

HTTP still works in Chrome but HTTPS does not.

Checked HTTPS in Safari and it worked fine.

Cleared all my browser data in Chrome but it didn’t do resolve the issue.

I Don’t have a custom DNS resolver unless that is something Comcast installed.

I created a new site called mylocalsitexyzabclocal.local but still couldn’t use HTTPS. Is that what you wanted me to do?

Checking through all of the security settings now. Will get back to you on that.

1 Like

I’m curious to know what you find since I’ve never been able to replicate this error on my machines.

One thing I noticed while reading through that IONOS blog post again is that they keep referencing a proxy as a potential source of the issue.

I bring it up because essentially, Local’s router (ie, the thing that translates a sites domain into the port that WordPress is listening on) is a proxy.

I know this is a lame question, but have you completely restarted the computer recently? I know I go days without a full reboot on my newer Mac, but my theory is that maybe Google Chrome is keeping around some connections to the Local router?

This issue has been going on for months(since I first tried an HTTPS connection with Local) and it’s been consistent across multiple work-spaces and internet connections.

Interestingly, I installed Firefox and tried to use HTTPS there but received the same error as Chrome. So HTTPS only works in Safari.


Secure connection failed

An error occurred during a connection to gravity-test.local. PR_CONNECT_RESET_ERROR

  • The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.*
  • Please contact the website owners to inform them of this problem.*

That’s a different error, but when I search for it, many of the topics seem related to the Chrome ERR_CONNECTION_RESET error.

One thing that I’m seeing mentioned is disabling any Firefox Add-ons or Chrome Extensions.

This is an interesting bit of info. You mention experiencing this across “multiple work-spaces” – do you mean different computers, or different sessions on the same computer?

Additionally, is this computer a personal machine, or is this a work computer where the IT department might have put their own SSL certificate within the chain?

Firefox doesn’t have any Add-ons but Chrome has six or seven Extensions.

I’m using the same computer in multiple locations. Also, I’ve restarted it quite a few times now.

It’s a personal computer but I do mostly work on it. No one touches it but me.

Is there a way to “reset” my internet settings somehow?

I tried searching for more info, and maybe the things outlined in this Quora answer would help:

  • Check your internet connection.
  • Test VPN connection.
  • Check firewall settings.
  • Disable Antivirus or real-time protection.
  • Check LAN settings.
  • Reset TCP/IP settings.
  • Clear browsing history.
  • Increase maximum transmission unit (MTU) size.

The very first way to Fix ERR_CONNECTION_RESET in Mac is to select “System Preferences” option and choose “Network’ icon. Now, select your choice network to get connected to and choose the ‘Advanced’ option. Navigate to the “Proxies tab” to uncheck everything located just under “Select a protocol to configure” icon.

Solutions to fix ERR_CONNECTION_RESET issues for Android or Mac

Well, we have a broad range of alternatives to overcome this issue, but here we’ll clarify just two of them. Let’s see what these are?

Step 1:- Check for any proxy settings if any

• Well, another computer system is a proxy server where the application for internet connection is accessible. But if you have it between your home and the remainder of your pcs, believe about it. There are proxies for a wide range of reasons, and the most common is because they need to filter web content in order to provide anonymity when the user is on the internet. So you need to solve this issue first to solve ERR CONNECTION RESET problems for Android or Mac users. Users may be able to verify at this stage in time why a proxy causes this kind of issue. This is because this site will not be viewed by the consumer. Therefore, conduct a test to deactivate proxy settings and verify what causes the mistake. Just switch it off to do this and check the mistake if it’s still there or not.

Step 2:- Clear your cache as well as cookies

This is another solution to fix the above error and to do this, perform the below steps:

Go to the “Settings option which is there in your browser to open it. Tap the “History option and check “History option”. Click on ‘Clear Cookies & Clear cache’ icon
Now, the next thing is to click on the button or tap the “OK” button to clear it out
This is one of the simplest methods as per Mac Support technicians. The process will clear out cookies as well as cache from the browser.

Step 3:- Disable the Anti-virus software if possible

• Anti-virus software is another prevalent cause of the issue because it can block websites. It’s because you’ve set the settings. Furthermore, from the software point of view, your website is not on a safe website. To deactivate the antivirus software, press the software icon and press “deactivate” button to deactivate it. Reboot your browser and attempt working again with the phone. Then uninstall and reinstall the software if it’s okay.

I hope all the above solutions will help you resolve the above problem. But, if the issue is still there then, approach at below contact details.

Hi Ben,

Thanks again for all the help.

Still having some trouble with this. Did everything he said except increase MTU size because I couldn’t figure out how to do it.

I cleared my browsing data and checked my proxy settings without success. Is there something I am not doing correctly here?


Stab in the dark here but I found my local-cert-generator folder in my user specific Application folder. Local app is in the main Application folder. Could this be what is causing the problem?

Ahh never mind, I think that was something I was using for MAMP.

Those settings under the “Proxies” section look like the same as what I have on my BigSur machine.

I’m definitely at a loss for what’s going on, but I’ll try to summarize things as I see them in case it helps us see something new.

  1. The machine is running the latest MacOS, BigSur
  2. Connections over HTTPS in non-Safari browsers return an error:
    • Chrome gives ERR_CONNECTION_RESET
    • Firefox gives PR_CONNECT_RESET_ERROR

The next thing I would try is creating a brand new user for the computer, install Local and Chrome, but don’t sync your Chrome profile (ie, just use the default, new profile)

This is mostly a test, but it would help zero in on if this is an issue with some sort of configuration setting within the user’s profile.


I’m not sure exactly what did it but after installing a new version of Chrome and Local it worked on both the new account I created as well as my main account.

Thanks for all the help ben :slight_smile:

1 Like

:partying_face: :larry_heart: :partying_face:

:joy: I hate it when I run into this kind of solution (I just want to know why!), but I’m glad you got it working!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.