ERR_CONNECTION_RESET in Chrome on all https sites

What issue or error are you experiencing?

I’m experiencing this issue, which was solved by updatin Local and Chrome.

My https Local sites do not work in Chrome, but they do work in Safari. The error is ERR_CONNECTION_RESET.

I have tried:

  • reset cache in Chrome
  • creating a new https site in local
  • removing all proxies, checking for firewalls (none), and not on VPN
  • verified certificates were trusted
  • restarted computer multiple times
  • all sites were working before MacOS 14

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

System Details

  • Local Version:
    Version 7.2.1+6433
  • Operating System (OS) and OS version:
    MacOS 14.0 Sonoma
    Chromium 117.0.5938.140

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @mitchell3417

Did this just start recently after an update? Or have you always had this issue in Chrome?

Just started after an update to Sonoma as mentioned in the post. All sites worked before that change.

Have you checked for any Chrome browser extensions that could be conflicting?

If you create a new, blank site in Local can you access that okay? If you can, then you may want to try reimporting the site getting the errors. The steps would look like this:

  • Locate the site files on your machine, and save a copy of them to your desktop. If you click Go to Site Folder under your site name it should take you right to where they are located.
  • Once you have those copied, completely delete the site from Local
  • Restart Local/your machine
  • Reimport the site back into Local. You can refer here on how to Restore from only Local site files

I have turned off all extentions with no change. I only had one installed.

This is true for all sites that have https. And new blank sites exhibit the same behavior.

If you manually change the url to HTTP instead of HTTPS will it load?

The new site will, yes, but the others I force to https

Have you tried deleting and regenerating a certificate to see if that works? That and some other troubleshooting steps are in our documents below if helpful:

I have tried a whole new certificate, and to no avail.

How are you forcing HTTPS on the previously built sites?

I’m not sure what else we could try here. For ease of work, you could try changing your Router Mode to Localhost which only allows for HTTP. This would be under Local Preferences>Advanced>Router Mode

This issue resolved itself.

Over the last few days, a browser update and Local update have come out. After running both updates, the issue is no longer present. It wasn’t working before the weekend. The only thing I did was run the updates, not even a restart, and it’s back to working as expected.

Thanks for your assistance.

1 Like

Glad to hear one or both of the updates helped to get this over the finish line for you @mitchell3417!