Error loading images to media library

I’m getting the following error message when trying to upload images into the media libraries of all my Local sites: Unable to create directory uploads/2017/07. Is its parent directory writable by the server?

Any help much appreciated.

Hi @Pigwah,

Sorry for the trouble! Is this on macOS or Windows?

Also, have you tried restarting the site? Sometimes that can resolve permissions issues.

Hi Clay,

it’s Windows. I have restarted the sites… still not resolved.

Was this site imported?

Also, are you using the “Preferred” or “Custom” environment?

Yes it was imported and I’m using custom environment.

Can you please try creating a new site using the “Custom” environment and check if it happens with the new site?

It’s fine with a new site, but still need it to work with imported sites… please help!

I can confirm that I was having this same trouble (on a Mac, running latest build of Local) but restarting the site did indeed fix this problem for me, fwiw.

Thanks, Restarting the site doesn’t fix it.

It’s fine with a new site, but still need it to work with imported sites… please help!

I’m having the same problem with a newly imported site. Using 2.0.7 pre-release, macOS 10.12.6, “Preferred” environment. Restarting the site does not fix it. (Also, unrelated, the reason I’m running 2.0.7 is that I had to upgrade from 2.0.6 to even import my site, in 2.0.6 it would just hang on “Extracting archive”.)

I also tried changing write permissions on the upload directory/sub-dirs to be writeable by all, and it still didn’t work.


Please try disabling Faster Docker Volumes under Preferences » Advanced in Local.


To remove the error you have to go to the database in to the options table wp_options, search for the upload_path in the columns option_name, delete the option_value (make it empty). Thats all, now the upload works again.



Thank you for this answer, it works for me :wink:

Hi I’m new to all of this.
I encountered the same issues with this images upload.
My question: How can I access the database? ( just open sql with editor? )
I’m on MAC

Thank you

// Update: //
I found the sql database and found the value, which I removed and it worked brilliant !
Thank you!