"Checking System........" forever

I’ve used Local in the past with the occasional issue but overall it’s been okay, I suppose.

Launched the app today (on MacOS, up to date with version 3.2.1) and I get stuck on the screen that says “Checking System” with no progress. I’ve quit and restarted the app several times with the same result. I even deleted the app and still have the same result.

Any help in getting this app working would be appreciated. Flywheel Support sent me here…

Hey @rob11521, Welcome to the community!

Can you please provide your local-by-flywheel.log file? See this Community Forum post:
How do I retrieve Local’s log file? for instructions on how to do so.

Since Local isn’t opening you can find the logs at ~/Library/Logs/local-by-flywheel.log

There might be more information about what Local is having issues within there!

local-by-flywheel.log (23.2 KB)

Log attached

Hey @rob11521

I’m seeing this in the Local log:

Jul 30, 2019, 11:17 AM EDT - info: [main/check-system] Check System: Docker Machine:  
{ stdout: '',
   'error getting state for host local-by-flywheel: exit status 126\n' }

That makes me think there is some sort of issue with the Docker daemon inside the Virtual Machine. Can you try restarting the VM by going to “Help > Restart Local Machine”.

If that doesn’t work, then follow the steps outlined in this topic to forcefully shut down and restart the VM:

Let me know how that goes! If you still are running into issues, can you provide an updated version of the Local log?

Thank you for your replies.

When I try to restart the local machine I get an error:
Uh-oh! We ran into a hiccup when trying to start the Local Machine. exit status 126

Trying the forceful restart process now.

I didn’t have Virtual Machine installed so I couldn’t do the forceful restart process. Downloaded it and installing now…

I have same problem.
local-by-flywheel1.log (1.0 MB)

Hey @cawa-93, Welcome to the community!

We are seeing the same error getting state for host local-by-flywheel. Did you try the steps Ben mentioned above?

Reinstall VirtualBox fixed my issue. How can I manually update VirtualBox?