Cloning has never worked for me

Windows 10
Local by Flywheel v3.2.1

I can manually clone i.e. by using the export tool but if I try to use the specific clone option it just seems to hang and I have to restart Local. Having done a quick search I’m not alone so was wondering what could be going wrong. I should add the clone function has never worked for me on previous versions!

Hi @GusGF -

So sorry you have been having this issue! Could you please send over the log files so we can take a deeper look into what might be causing this issue?

Here are the instructions on how to get log files if you need it: How do I retrieve Local's log file?


I am having the same issue. Clone does not work, then I have to reboot to get everything working again. I am on a Windows 10 pro machine.

Please find attached the said log file.

Many thanks

local-by-flywheel.log (267.8 KB)

Welcome to the community @dzunker

Can you describe in a little more detail how you are trying to clone a site? For example:

Hey @GusGF

Thank you for that Local log! I do see a couple of errors that seem to indicate that Local is having trouble communicating with mysql. The specific lines looks like this:

Apr 29, 2019, 9:04 PM GMT+1 - warn: [main/SiteModel] wpInstalled not returning "installed" 
{ message: '',
   'Error\n    at C:\\Users\\Gus\\AppData\\Local\\Programs\\local-by-flywheel\\resources\\app.asar\\main\\actions-sites\\wait-for-mysql.js:1:2853\n    at (<anonymous>)\n    at _0x5bab70 (C:\\Users\\Gus\\AppData\\Local\\Programs\\local-by-flywheel\\resources\\app.asar\\main\\actions-sites\\wait-for-mysql.js:1:1645)\n    at C:\\Users\\Gus\\AppData\\Local\\Programs\\local-by-flywheel\\resources\\app.asar\\main\\actions-sites\\wait-for-mysql.js:1:1904\n    at process._tickCallback (internal/process/next_tick.js:68:7)' }

Since this appears to be related to the database, a couple of follow up questions:

  • Is the site turned on when trying to clone the site?
  • Are there any MySQL errors contained within the logs/mysql/error.log file for the original site? You can zip up the logs folder and attach it here if you’d like me to take a look as well.

Okay thanks now it’s worked and the key seems to be that the site you want to clone should be on. Since clone was available as an option for sites that were both on or off I thought it didn’t matter. Perhaps this needs to be made clear as I have searched and didn’t see anything stating sites should be on. And maybe for sites that are off the cloning feature should be unavailable. Typically when cloning a partition on an OS the partition is unmounted so I applied the same logic.

Thanks for that feedback @GusGF! I’m adding these notes to some work we have in the backlog for working on cloning sites!

1 Like

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.