Local Community

Concerned About Database Corruption

Tried to update plugins and they failed and kicked me to maintenance mode which I removed from my Windows 10 OS as suggested by other similar threads in this forum. Site is working again.

My question is: whether I should be worried about a corrupt database similar to what happens when this occurs on my live sites?

Has anyone else using Local had a similar experience? Should I just start over to be safe?

Hi @nootkan

Was this a site you imported or built-in Local? I’ve not run into this myself but is the site still hosted somewhere? Are you able to get it scanned with something like Wordfence, Sucuri, etc?

This is a site I created from scratch using Local. It is a redo of a site that I cannot seem to fix on a live server. For some reason the live site has issues that show up every morning after I update the homepage the day before. Been trying to resolve it for over a month and just decided to start over using Local. When I tried to update a plugin on Local it failed and I was concerned as that is exactly what happened to the live site before all the issues. Started another project with a different domain on Local and no issues so far. Plugins updated fine. I’ll keep trying to figure it out.


Hi @nootkan -

Good luck and please let us know if we can help you figure out this issue, it sounds like it might just be a problem with one of the plugins!


Okay just thought I’d let everyone know that it turned out to be a corrupt database that occurred after one of the plugins failed. Apparently it happened a couple months ago and was only noticed by me recently. I had to install the original backup from when I first built it back in Oct 2022 and add all the new content and products, order, customers etc afterwards. Happy to say everything is back to normal and the client is happy. I deleted the plugin and convinced them to use another one in its place. Thanks for the support and great product for building wordpress sites locally.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Hi @nootkan -

Thanks so much for following up and letting us know what was going on! Glad you have it all working now :slight_smile: