Dest already exists when Importing or adding from Blueprint

I’m using the latest version of Local by Flywheel (5.0.7+1117) on a mac running Catalina. I’ve created an install which I now want to clone. However, no matter how I try to do this i get the same error message: “dest already exists”.

I’ve tried this by making a blueprint from my master install and then adding a new site using that blueprint, and by exporting the site and then attempting an import from that .zip.

According to this article – – there should be a “clone” option in the right-click menu in the LH panel of Local but my menu simply doesn’t have that option, whether the site is running or not.

This means that the app is pretty much useless for me now, and that’s a shame since i put a chunk of work into that initial master. Is there any way round this? I’m aware the issue has been raised at Error: dest already exists but no answer seems forthcoming there.


Hey @chfqx, we’re really sorry that you’re running into this. The article from Layout is from August, when the “common” version of Local was version 3.3.0. Then Catalina came onto the scene and we’ve focussed our efforts on getting the newest iteration, Local, to market (currently 5.0.7, that you have). This version does away with some of the most common issues we’ve had with Local by Flywheel, notably VirtualBox integration. It’s also fully compliant with Mac OS Catalina but there are some features, like Cloning that are not yet built in to version 5.0.7. Again, we’re sorry about the disconnect there and we’re working hard on getting those features added back into Local once again.

As far as working through the original issue, if you’re still working on that would you please provide your local-by-flywheel.log file?

See this Community Forum post for instructions on how to do so > How do I retrieve Local’s Log?

Thanks Matt. I’ve had a little support from your team on this issue and have found a workaround for the blueprint/import issue. I am now able to create a fresh copy of a site using this workaround:

  1. Export the site on your Desktop,
  2. Extract the zip file that you’ve exported and there should be a file named local-site.json open this file with a text editor and inside there look for the following:

"path":"/Users/username/Local Sites/testname" (Please note your file might looks different than my example)

The only thing we want to change on this is the name of the site after the Local Sites/ path (for the example above I’m changing)

"path":"/Users/username/Local Sites/testname" to `“path”:“/Users/username/Local Sites/Writeadiffernetnamehere”`` (wirte 1 word with no spaces in the sitename)

Obvioulsy it’s not an ideal solution but it’s workign right now – hopefully it will help anyone else here. I’ve got my fingers crossed for either the addition of cloning to Local or a fix to this weird "dest already exists’ issue when creating a new site from a blueprint in the longer term.

Happy to provide the log, but how do you want that supplied?


Happy to hear that you’ve been able to get a workaround working for now.

Since it looks like you’re having to sidestep the Blueprint altogether, you might be able to avoid editing the json by removing it (and the /conf/ folder) from the archive that you’re using to drop into Local to create a new site, essentially having an external Blueprint.

We know that this has popped up for a few folks, so it is definitely in front of our Local dev team!

Do you think that

is going to be the permanent solution here?

I guess i was holding out for a fix in a future version? : )

Not a permanent solution, no. This is a workaround for sure that we plan to have fixe in a future release.

I have been having the same issue. Strangely, I have a couple of blueprints, one of which works, and the others that I have tried to make send up the same error.

I will add my log local-lightning.log (127.0 KB)

Hope this helps solve it!

Running 5.2.3+2248 on Windows 10 here. Still the same problem.
I’ve been looking into the log file, and noticed the error here:

{"stack":"Error: dest already exists.\n    at C:\\Program Files (x86)\\Local\\resources\\app.asar\\node_modules\\fs-extra\\lib\\move\\index.js:46:31\n    at C:\\Program Files (x86)\\Local\\resources\\app.asar\\node_modules\\universalify\\index.js:23:46","level":"warn","message":"Unable to import site.","timestamp":"2020-02-02T16:35:57.785Z"}

I found the mentioned directories, and noticed that they’re not there. There is a file called app.asar though, which I can’t open as folder.

Here’s the full log file
local-lightning.log (237.6 KB)

Tried exporting/importing as well, same error.

For now, WPvivid backup plugin does the job. Just not as straightforward.

I hope this helps fix it.

Unzip the folder. Delete the conf-backup folder and rezip. Then import into Local.

1 Like

Me also is form a lot of time that’s impossibile to import blueprint except only one (the first that i’ve created)
Is there a solution withot to extract and chanhe path etc etc ?
thank You

P.s. i’ve discovered that recreating , from begin, a new bluprint image, it is possible to import but if we import a blueprint and we work on it adding others plugin and we create a new bluprint this is impossible to can be reimported.