Error: dest already exists


Trying to reimport a site I exported, then deleted. Currently Local has no sites, all have been deleted. On importing the zip file created with Local. I’m getting the following error message

1 Like

Hey @DudeneyGe, the import process is probably trying to put the files in the same directory that was used before. Would you check and see if the previous folders exist by going to your Finder > Home Directory (from the Sidebar) > Local Sites and seeing if previous site folders are present. If they are (and you don’t need anything in them), go ahead and delete them. Then try to import the site again.


Many thanks for this. I wish it were that simple, but I had already emptied the directory out. This is still happening today, even trying to set up a new site from a blueprint. It’s such a pity because I love Local and I really do want it to work for me.

Have you updated to the latest version of Local?

I have. I may do a complete uninstall and start from scratch, even though it will mean remaking my blueprint. I appreciate your taking the time to get back to me here - thank you.


Any solution for this problem ?

I got the same, impossible to import my site or to create it again with blueprint … So sad

1 Like

@DudeneyGe @nathanch

I just tried importing an export and creating a site with a Blueprint in Local 5.0.6 on macOS and wasn’t able to reproduce the issue. This isn’t the first time we’ve seen reports of this so I definitely want to get to the bottom of it!

If possible, can you both provide your local-lightning.log files? See How do I retrieve Local's log file? for instructions on how to do so.

Hi, thank you for the response.

Here is the log file :
local-lightning.log (56.5 KB)

Hi, today i tried to export a site from my macbook pro and to import it to my windows pc and i got the same error :sob:

If you find anything please share it with me, i need so much to export my site to an other pc for customer meeting (2.6 KB)

Same problem for me… here’s another log in case it helps.

I have the same problems on windows platform, and unable to reinstall Local 3.30 :frowning:

I have the same issue and still no solution. Is anyone working on this? Thank you.

One more occurrence of this problem here.

Export site (because of SSL error), delete site, manually delete SSL cert, make sure folder in Local root is gone, quit Local, reopen Local, try to re-import just created Local archive zip --> “Unable to import site: dest already exists”.

Creating instead of importing exactly the same site works without any problem.

The error log lines would appear to be these

{“thread”:“worker”,“worker”:“analyzeImportWorker”,“level”:“info”,“message”:“Analyzing Zip: Listing Contents for Local Export Check”,“timestamp”:“2019-11-05T08:11:09.723Z”}
{“thread”:“worker”,“worker”:“analyzeImportWorker”,“level”:“debug”,“message”:“Analysis of zip: Local Export”,“timestamp”:“2019-11-05T08:11:09.724Z”}
{“thread”:“worker”,“worker”:“analyzeImportWorker”,“level”:“info”,“message”:“Analyzing Zip: Listing Contents for Generic Zip Check”,“timestamp”:“2019-11-05T08:11:09.725Z”}
{“thread”:“renderer”,“component”:“ImportSiteAnalyzePage”,“level”:“info”,“message”:“Message from import-site-analyze-worker:”,“timestamp”:“2019-11-05T08:11:09.974Z”}
{“thread”:“main”,“class”:“ImporterLocalExport”,“level”:“info”,“message”:“Removing /var/folders/jm/cvg59wy11xn_dm3bktq40xyw0000gn/T/local-by-flywheel-CzPJNAnr5q”,“timestamp”:“2019-11-05T08:11:40.431Z”}
{“thread”:“main”,“class”:“DeleteSiteService”,“message”:“Deleting /Users/philby/Library/Application Support/Local/run/upEzmbGWC”,“level”:“info”,“timestamp”:“2019-11-05T08:11:40.432Z”}
{“stack”:“Error: dest already exists.\n at /Applications/\n at /Applications/”,“level”:“warn”,“message”:“Unable to import site.”,“timestamp”:“2019-11-05T08:11:40.481Z”}
{“thread”:“main”,“class”:“Process”,“process”:“nginx”,“pid”:19598,“level”:“info”,“message”:“Killing process”,“timestamp”:“2019-11-05T08:11:55.080Z”}

I had this error and ended up deleting the conf-backup folder inside the zip i was importing. I left all other files and folders intact. Worked a charm - YMMV. I dunno if the import is parsing through the zip file and then tries to also import from the conf-backup folder and then cancels the import?

1 Like

Hey @philby, would you try opening up the archive and pulling out the /conf/ folder, zip it back up and try importing it?

Importing the zip without /conf/ was more successful: no “dest already exists”.
However, I got bitten by the other “Uh-oh! Unable to import site” error…18

Well that is at least progress! It looks like there is a problem with importing the img_optm.sql table. Previous versions of Local backed up each table to it’s own SQL file in the /sql/ directory when site services were stopped. There are probably several SQL files present.

You might be able to find out why the SQL is failing by opening it up and looking at the statement on line 1. That table may not be critical to importing the site but would you send a screenshot of all the SQL files that show up there?

Hi, Matt - the conf-backup folder was the problem and the one I removed. I left the conf folder intact.
I think the importer is working through the /conf/ folder and then also trying to import from /conf-backup/ - hence why I deleted conf-backup

1 Like