Document Root keeps point to default “It works!” page when using "Site Domains"

What issue or error are you experiencing?

When I’m starting any site from within WP Local, it just keeps on showing “There is a portal conflict with this site’s domain.”
I used to previously stop other processes listening to port 80 and that’d ultimately allow Local to display my sites using “Site Domains” but after I’ve updated to latest version 8.3.2 this has stopped from working. I have tried closing down Local, killing any process listening to port 80, open Local and problem would still persist. I can happily work with “localhost” as a router mode however I need to work on some multisites locally and that’s only available with “Site Domains”.


What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc



image


System Details

  • Local Version: v8.3.2

  • Operating System (OS) and OS version: MacOS Apple Silicone - v14.2.1 (23C71)


Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)
logs.zip (94.3 KB)


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @alex.pascal

Are you running other developer applications simultaneously? That could also cause similar issues. Apps like MAMP, XAMPP, or Docker for example.

Are you running the command lsof -nP -iTCP -sTCP:LISTEN to check for listeners on the ports?

Hello @Nick-B ,

Thank you for coming back to me. I never used MAMP or XAMPP running locally but now I remember I used to have Docker installed and I think I had issues getting rid of it but I’m unsure if there’s still traces of this that’s blocking my WP Local from running?

With WP Local shut down, here’s the results I get after running the above command:

Have you tried killing those off yet to see if Local works normally afterward? I would try using sudo kill -9 XXX where XXX is the PID number of that process and then testing with Local again.

Good afternoon @Nick-B ,

I have been running this option in the past, e.g. killing anything that’s not WP Local process and it would work just fine when I would find culprit process however it hasn’t worked at all recently?

I have been using the localhost routing since I’ve had this issue and it worked fine however I’ve got some multisite WordPress installs and those can only be ran if I’ve got Domain Name enabled.

I haven’t either installed anything new that could potentially be listening to port :80

So when you switch to Site Domains mode do you run into trouble when working on any sites? Or is it just the multisite or once the multisite is running?

Good morning @Nick-B ,
When I switch to [Site Domains], all I get on the frontend is the plain text [It works!] (only if I’m typing in the URL without https:// in front, otherwise it just does a ERR_CONNECTION_REFUSED) and I can’t access the WP backend or any other pages.

Below is an example of my active results for lsof -nP -iTCP -sTCP:LISTEN

I don’t understand why I’ve got 4 nginx processes and 3 mysql for a single WP Local site active?

@alex.pascal Have you tried rebooting recently? That should kill any runaway processes generating port conflict messages.

If that doesn’t help and you’re confident that other processes running on port 80 have terminated (sudo lsof -i :80 should give no results when Local is closed), you could try making Local regenerate your nginx folder and nginx configs in case they’re missing or corrupt (if it is Local serving the default “it works!” nginx message, it suggests nginx is mis-configured):

  1. Stop your sites and close Local if it’s running.

  2. In the Finder, choose Go → Go to Folder.

  3. Enter ~/Library/Application Support/Local/lightning-services/ and press enter.

  4. In the Finder window that opens, delete the folder with a nginx- prefix, as well as the mailpit-1.12.1+0 folder (you seem to be missing that too in your screenshot above):

  5. Double-check that nothing else is running on port 80 (sudo lsof -i :80 should give no results).

  6. Launch Local. It will see that nginx and mailpit are missing and copy them to the lightning-services folder you were just looking at.

  7. Attempt to start and visit a site.

1 Like