Error 500 when trying to create an account on the official site

Heading over to and trying to register is not happening in my case.
No matter how i try to register, i get this 500 error message in the center of the screen.

Hi @ChrisManiac - thanks for trying out Local!

Can you share a bit more information (or even screenshots) of what you’re seeing? The entire page throws a 500 for you? I just tried to create a new account with an old e-mail of mine and got through the flow successfully.

I will try looking at our server logs too to see if there is a record of the 500.

I’ve attached 3 images of the process.
Using Google in this instance but it really doesn’t matter which approach i choose.

Tested in Firefox, Chrome and Safari, they all bring the same result.
Using a MacBook Air M1.
Location: Denmark.

Hope it helps to narrow down the incidence.

Hey @ChrisManiac! Have you tried with a VPN or would you be able to test that?

Hi Nick-B,

Makes no sense to make a country specific login requirement.
Have not tried it and properly wont :slight_smile:

Hi @ChrisManiac no worries I was suggesting it as just a possible workaround in this instance. It certainly should be working as we have no geo-blocking in place, certainly not for your area. What about testing it via LTE Data instead of a WiFi or wired connection?

Em @Nick-B, i tried your suggestion but non of them worked :slightly_frowning_face:

  • Tried a VPN
  • Tried a 4G/5G connection instead of my home WiFi.
  • Tried all the different signup options.
  • Tried in Firefox, Chrome and Safari.

I’m truly amazed how this can be a problem :smiley:

Hi @ChrisManiac - We are a little stumped here. A couple of us in the United States have tried creating new accounts without issue, and today I asked two of my peers located in the UK and Spain to test and they were successful as well. We haven’t been getting complaints from any other users either.

I wonder if something with the pre-loaded accounts here is causing an issue: Image 2022-11-05 at 10.01.1...

Instead of Choosing an account, can you try going to Local Hub and creating one manually with the form?

Hi @Nick-B, thanks for sticking around and investigating the problem :muscle:
Not sure how or why but i managed to create an account yesterday using the Google method :thinking:

Sad thing is, we don’t know exactly what caused the problem, my macbook is fairly clean, i don’t really have any apps installed so i doubt it could’ve been that.
I am using a 5G wireless connection, then again, i tried multiple times with all the methods so i doubt that’s the case aswell.

I hope you solve it somehow or that no one else runs into this issue.

Thanks again and take care :slight_smile:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.