Error 502 on custom enviroment [solved]

Hi guys, I had recently a problem with one particular website which didn´t want to start. Firstly it took forever to start and then after few minutes the error 502 appeared. Even when I clicked on “Stop the website”, another error came along: “MySQL cannot be reached, the backup failed”. I restarted local, VM and nothing happened. But now, I solved it and I want to tell you how. So, as the headline says that the “non-working site” was in custom enviroment [ mine was on PHP 7.2.0, APACHE and MySQL 5.6 and I was using Win 10 ]. After a little research I found out, thanks to Flywheel support, that the Local app cannot find the SQL database. I went to site´s folder and to /conf where the SQL should be. But, it wasn´t there. I thought it was really weird. Another folder was there (very similar to /conf) --> /conf-custom-1.2.0 where the SQL and all stuff was placed. Easily, I deleted the /conf folder and renamed the /conf-custom-1.2.0 to /conf. Now, everything works. I don´t know why local created another folder with php, sql… But I can say that if you have similar problem to mine, this post might SAVE YOUR BUTT :wink:

Thank you very much. I had a duplicate/similar folder, but it started with/ apache

Cheers dude