Local by Flywheel 3.3.0 custom site creation

If I create a local site with the defaults nginx - php 7.2.9 - mysql 5.7.23 everything creates perfectly! Sadly this is not the preferred method for 90% of my clients.

So… what do I do? apache - php 7.2 - mysql 5.6 … nothing ever loads.

Unable to fetch WordPress version.

Every directory (app, conf+sub-directories, logs+sub-directories) is empty. Not good.

Looks like there are no PHP files to build the platform with.

attached *.log filelocal-by-flywheel.log (942 Bytes)

Hey @troybrisbin -

Looking at the Local log, it seems like for whatever reason, the files necessary for creating that custom environment don’t exist.

When you try creating a new Custom site, does it go through any steps for downloading additional environments?

Can you also open the “environments” folder by selecting “Local Menu > Reveal Local Router’s Log” and then open the “environments” folder. There should be additional folders for each environment that Local has downloaded.

In the case of your Local log, it is expecting there to be a custom-1-3-0 folder with the necessary files needed to create the environment.

If that folder doesn’t exist, can you try creating a new WordPress site using those same custom settings?

Hi Ben,

Firstly, I watched it create the folders and then it just stops. I would let it spin for 30 minutes, work on something else, come back and kill it. It was acting like it cannot access the necessary download files/directories for local creation from the servers. I read the log and can see where it is stopping. My guess, it wasn’t communicating with your servers.

When I tried to create a WordPress press site after the above failure, it never completes and I have to force it to quit. When I open it again none of the WordPress files and/or directories can be found. Which would be correct because the PHP, Apache never installed.

Again, I saw that the folders were empty and that is why I sent in the ticket.

I will try it again, but before I do; Question, can I run two separate versions of LBF side-by-side?

I went back to 3.0.5 and it works perfectly (issues started with 3.2 (Intermittent BSOD) and 3.2.1 (BSOD every time on startup). I will try it again but would prefer to not have to remove everything (clean-up all folder locations, registry, etc.) in order to have a clean install of 3.0.5 if it still fails.

Thank you,

PS: Replying to your email keeps bouncing back as unknown email address.

Hey @troybrisbin

That’s all quite odd and makes me think that there has been an issue with that version of Local on Windows.

Since Virtualization has been causing a lot of issues, especially under Windows, we’ve removed that dependency, and with the 5.x version of Local, many of the issues that are like this one have been resolved.

Can you try installing the most recent version of Local from the Community Forums:


To your question about running two versions of Local side-by-side – you can definitely run the 3.x version of Local alongside the 5.x version. With the 3.x version, we don’t recommend switching back and forth between those versions (for example between 3.3.0 and 3.2.4) because they are sharing the same Virtual Machine.

Hope that makes sense. Let me know if you have any other questions!