Error trying to provision site. HELP Please

Issue Summary

I’m no longer able to provision a website. I’m getting a MySQL error.

Existing sites will launch, but not if I create a new one.

Now that Local is FREE how do I get priority support? I used to pay for it. I really need help here. I’m willing to pay someone to troubleshoot this for me, I use Local for work.

Is there a way to backup all my sites and do a complete re-install? I can’t afford to lose existing sites.

I need this solved ASAP!!! Please help.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular? All new sites

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser? No


If I try to create a new site or clone a site I can’t. I get the error below. If I try to create a custom site using MySQL 5.7 it works, but then I get an HTTP error 426 in the browser.

System Details

The current version of Local, MacOS

{"thread":"main","service":{},"serviceBinVersion":{},"stack":"Error: Command failed: %%resourcesPath%%/lightning-services/mysql-8.0.16+6/bin/darwin/bin/mysqladmin ping\n\u0007mysqladmin: connect to server at 'localhost' failed\nerror: 'Can't connect to local MySQL server through socket '%%site.runData%%/mysql/mysqld.sock' (2)'\nCheck that mysqld is running and that the socket: '%%site.runData%%/mysql/mysqld.sock' exists!\n\n    at ChildProcess.exithandler (child_process.js:317:12)\n    at ChildProcess.emit (events.js:315:20)\n    at ChildProcess.EventEmitter.emit (domain.js:467:12)\n    at maybeClose (internal/child_process.js:1048:16)\n    at Process.ChildProcess._handle.onexit (internal/child_process.js:288:5)","level":"error","message":"Database did NOT respond to ping after 15 tries.","timestamp":"2021-10-16T21:57:39.429Z"}

That’s an interesting error – notice the two in parenthesis? It’s almost like there’s an existing socket within the run folder for the site.

I know this is a tired response, but have you tried doing a full restart the computer? That might clean up any lingering processes that are keeping that socket file around and allow you to create a new site.

If that doesn’t work, then I would recommend taking backups of your existing sites and then trying completely uninstalling Local and re-installing it. Here’s a help doc that outlines some of the things to do to uninstall Local:

Hey Ben,

Thanks for the response.

I’ve restarted at least a dozen times.

I think I’ll have no choice but to backup and reinstall.

Well, I ended up reinstalling about 2 months ago. everything was fine. Then this morning it happened again.

I’m no longer able to create a new site.

Anyone else have this issue, or a solution?

I was able to provision a site using a custom install and changing the MySQL from V8 to V5.7.

But the site throws an error “HTTP Error 426”.

This also happened last time.

OK, so this might be a bug/issue with Local WP.

Everything was working fine yesterday. I had to do some work on a site so I downloaded and imported it from WPEngine. This was a very large site.

I just deleted it from LocalWP, and all of a sudden I can now provision new sites.

I have no idea why, but it’s the only thing that had changed in my system.

Some more detail on this.

This error keeps popping up randomly. The only fix so far seems to be if I delete an existing install, any random existing install. Then afterwards I am able to add 1 new install before the error repeats.

I’ve tried restarting many many times.

I have 1.2TB of space left, so that’s not the issue.

I use LocalWP for work, so this is such a huge issue. I’d be willing to even pay Support for this if that was an option.

Reinstalling every time this happens is just not a great option.

Thanks for listening.

I’m having similar issues. Did you ever get closer to a solution?

Hi Erik,

No, I have to reinstall every few months.

LocaWP is no longer a paid option, so sadly there isn’t much you can do.

I’ll probably move to Laravel Valet in the future if this keeps happening.

I’m not blaming LocalWP, but I use it for work, so I need it to be flawless, or have the support to get things fixed.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.