Got the Uh-oh Unable to Provision site (Mac)

I recieved the following everytime i want to create a new site:

Error: Error: Command failed: /Applications/ --password= ping
mysqladmin: [Warning] Using a password on the command line interface can be insecure.
amysqladmin: connect to server at ‘localhost’ failed
error: ‘Can’t connect to local MySQL server through socket ‘/Users/$$/Library/Application Support/Local/run/9a-awRguJ/mysql/mysqld.sock’ (2)’
Check that mysqld is running and that the socket: ‘/Users/$$/Library/Application Support/Local/run/9a-awRguJ/mysql/mysqld.sock’ exists!

at ChildProcess.exithandler (child_process.js:304:12)
at ChildProcess.emit (events.js:223:5)
at ChildProcess.EventEmitter.emit (domain.js:475:20)
at maybeClose (internal/child_process.js:1021:16)
at Socket. (internal/child_process.js:430:11)
at Socket.emit (events.js:223:5)
at Socket.EventEmitter.emit (domain.js:475:20)
at Pipe. (net.js:664:12)

Tried to uninstall and reinstalling with not help.


I restarted my Mac, then went to security and privacy and allowed LocalWP to have full disk access.Worked.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.