Local Community

"Error while updating" - MacOS Monterey v12.6

I’ve just been prompted to update Local, failed to update.

“…Local.app/ did not pass validation: code failed to satisfy specified code requirements(s)”

I’ve recently updated to MacOS Monterey 12.6

Local v6.4.2+6012

Hi there,

Same thing is happening to me. I tried about 10 times and always the same error message.
Im still on MacOS Monterey 12.5.1
Would be great if they come up with a solution. Its frustrating because these issues happen so often.

Thanks for reaching out!

We’re still trying to get more info around this issue, but as a test, can you try manually downloading and installing Local from the Releases page on the website?

Can confirm manually downloading and installing from the Releases page worked!

1 Like

I am trying now to update and when complete downloading it give the below error " I have the same error with the live link "
Code signature at URL file:///Users/mahmoudsaif/Library/Caches/com.getflywheel.lightning.local.ShipIt/update.pBRcOLk/Local.app/ did not pass validation: code failed to satisfy specified code requirement(s)

Hi @mahmoudy2k - I moved your post here to keep conversation in the same place. Can you try downloading the latest release from localwp.com/releases and confirm this resolves the issue?

We’re looking into why that auto-update functionality is throwing the error.

1 Like

Hey @Jim_Savage_BT @micahash @robertkollar @mahmoudy2k

As we try and zero in on the exact issue – what kind of a Mac do you have? The older “intel Macs” or the newer M1 “arm64” Macs?

Also, can you let us know what version of MacOS you are running?

I had just updated to Monterey version 12.6 prior to attempting to run the updater. I’m using an M1. Not sure if it was related to the OS update, but I noticed afterwards that Full Disk Access was turned off in my settings for all apps.

1 Like

I have a 2017 MacBook Pro with 3.1GHz quad-core Intel Core i7 processor
I’m updated to MacOS Monterey 12.6 and still this error is present

1 Like

I have exactly the same issue however the .dmg worked fine. I have an iMac (27-inch, Late 2013) running Catalina.

UPDATE: installing the .dmg file from the release page worked for me.

macOS Monterey 12.6
Intel based Macbook Pro 2020
Processor: 2 GHz Quad-Core Intel Core i5

1 Like

MacPro M1, 2020, OS monterey

Many thanks it’s working now. :slight_smile:

@austinwendt still facing a problem with the installation

1 Like

Same here. any workaround? @austinwendt

@mahmoudy2k glad that worked for you! @nik_dev you can try the same, download the latest build from localwp.com/releases and you should avoid the error.

We updated our signing certificate from Flywheel to WP Engine with this build, and it appears MacOS doesn’t like that the signer changed… now to figure out how to get Apple to recognize it was intentional!

2 Likes

@austinwendt Got it sorted !! Lovely cheers!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.