Local Community

Error - wont let me create new site

i have had local installed before but updated and now not working with the following error
have uninstalled and re-installed and still the same

Error: Command failed: /Applications/Local.app/Contents/Resources/extraResources/lightning-services/php-8.1.9+8/bin/darwin/bin/php /Applications/Local.app/Contents/Resources/extraResources/bin/wp-cli/wp-cli.phar --path=/Users/neilrichards/Local Sites/playground/app/public --require=/Applications/Local.app/Contents/Resources/extraResources/bin/wp-cli/local-wpcli-error-reporting.php --skip-plugins --skip-themes core config --skip-check --dbname=local --dbuser=root --dbpass=root --skip-salts
dyld: lazy symbol binding failed: Symbol not found: ____chkstk_darwin
Referenced from: /Applications/Local.app/Contents/Resources/extraResources/lightning-services/php-8.1.9+8/bin/darwin/bin/…/dylibs/libpcre2-8.0.dylib (which was built for Mac OS X 11.0)
Expected in: /usr/lib/libSystem.B.dylib

dyld: Symbol not found: ____chkstk_darwin
Referenced from: /Applications/Local.app/Contents/Resources/extraResources/lightning-services/php-8.1.9+8/bin/darwin/bin/…/dylibs/libpcre2-8.0.dylib (which was built for Mac OS X 11.0)
Expected in: /usr/lib/libSystem.B.dylib

Hi @neilr2096! Can you share your Local Log with us? There are some different ways to access and share Local Logs. For us to be able to troubleshoot thoroughly, please click the Download Local Logs button from the Support tab in Local. This will generate a zip archive that contains the Local log along with some other diagnostic information to help quickly zero in on any issues that Local is encountering.

it doesnt even load a wordpress version just loading the dots

It will only allow me to run PHP 7.3.5 - if i try and select any highter version it just will not load even the page to show the wordpress version

Thanks in advance

Log Attached
Thanks in advance

local-lightning.log (87.1 KB)

Hi @neilr2096

What is your OS version? If it’s working on PHP 7.3.5 it might be an issue with your OS version reaching EOL.

10.13.6 (17G14042)
Yes works well, except its an old version

I imagine EOL stand for End of Life, but is there anything we can do to get it to work with the latest PHP Versions?

Hi @neilr2096

Nothing unfortunately other than updating your OS to something more current.