Local Community

Errors Importing Site Starter from Blocksy

Issue Summary

IMporting Starter Site from Blocksy, encountered errors. Mentioned there were issues with server execution time/server config. Looks like it uploaded half the site, and is now giving me the screen below when viewing site.


Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    The last two recent sites I have attempted.

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?
    Yes.

Replication

Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!
Created a new site in Local, Added the Blocksy Theme, Added the Blocksy Pro Companion Plugin.
Went to Blocksy > Starter Sites > Selected Barber Shop > Import.
Selected the Elementor Version, all other details left the same. Upload took a while, sat at 42% for a bit, then eventually gave me this error:

System Details

  • Which version of Local is being used?
    Version 6.5.2+6204
  • What Operating System (OS) and OS version is being used?
    • For example: macOS Catalina or Windows 10 Professional
      Windows 10 Home
  • Attach the Local Log. See this Help Doc for instructions on how to do so:

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi there @ekbb - welcome to the Local community! :wave:

Have you reviewed this article through Blocksy support, by chance?

There are lots of helpful troubleshooting tips in there that sound specific to the issue you’re facing.

Want to give that a try and let me know if that helps?

Sam

Yes, I have reviewed that article. I reached out to the folks at Blocksy, and this was their response:

Hi Emily,

Very, very strange, as we use localwp as well and importing works perfectly.
Are you sure there’s no other application running that might interfere with this process? This should be working a-ok, really. :frowning:

And for the errors that you’ve sent us, I’m afraid that these are Warnings related to Elementor. You might need to contact them to have them solved, as we do not have much power over the Elementor plugin.

One important question – have you tried using the importer with an older PHP version?

Thanks,
Eduard

Is there a better version of Php I should use?

Hi @ekbb -

Thank you for that context. Have you happened to contact Elementor support as they’d suggested?

I’m not sure that there is a better PHP version to use, but you could try 8.0(+) instead of 8.1.9 and see if that helps.

You can update the PHP version in the Local app.

Let me know if that helps,

Sam

Hey Sam,

Yes, I have contacted Elementor support as well, this was their response:

Hi Emily,

Thank you for contacting us. I am Rakesh from Tier2 Customer Experience.

I tried to import the Blocksy starter site that uses Elementor but didn’t face any issues. So, it may be a temporary issue or issue in your local environment.

I suggest uploading the website online and contacting Blocksy theme support as the demo contents and layouts are provided by them, and they will be in the Best Position to help you in this regard.

I hope it helps.

Best regards,
Rakesh

I am awaiting on another response from blocksy support. But I am also a little frustrated with the go-around. :confused:

So strangely enough, my other site on local was created with the same settings as this new one, on November 15th.
I went to re-import a starter site just to see, and it worked fine.
Is there a reason that it works for one of my sites but not the other?

Hi there, @ekbb -

Hmm, odd. Is it possible you updated Local since?

I know you mentioned the rest of the settings were the same.

Have you tried restarting Local, stopping all of your sites, and trying again?

Sam