Every time only i can see the PHP versión Page

Currently I have High Sierra MAMP, Docker Desktop installed on my MAC and I had Virtualbox installed now that I want to install Flywheel Local whenever I try to enter the only page that appears is the PHP Version, surely there is some conflict and I would like to help me solve it , I have tried with Apache, Nginx, changing the PHP versions but it is not enough, it always shows the php version, the database manager works fine.

Hey @andres-dev – Welcome to the Local Community Forums!

Looking that that “Conifgure Command” from the php version page, it looks like it’s referencing this path:


That’s the location of PHP that’s installed via Homebrew. Have you manually installed Apache or PHP using Homebrew?

Local has a feature called “Router Mode” which allows you to choose between using localhost or a human readable site-domain (something like example.local) to access the WordPress site. You can change this setting by navigating to the “Preferences > Advanced > Router Mode” page.

For more info about “Router Mode” as well as some troubleshooting steps for stopping whatever process is occupying port 80 (the default HTTP port), see this help doc:

Ohhhhh @ben.turner thanks for the solution, now it’s working but only i can work with Localhost url + ports for example (localhost:10003).

Have you manually installed Apache or PHP using Homebrew? the answers is yes, how can i solve this problem, or how can i uninstall Apache, PHP and Mysql using Homebrew to continue using Local with site domains?

If you’re wanting to use the “Site Domains” router mode, you can, you just need to stop that Homebrew version from running.

I’m not 100% sure without knowing which package was installed. You’ll need to figure out what package was installed, which might be found here:

In general, uninstalling things with brew looks like:

brew uninstall <package-name>

Another option would be to zero in on what the specific process is and stopping it. You can figure out what process is listening on port 80 with this command (it will ask for your admin password):

sudo lsof -i:80; sudo lsof -tnP -i:80 | xargs -n 1 ps -p

From there, you should be able to figure out what the specific process is running and then stop it gracefully.

Can you look my process? Avast? I’m not sure if this is my Virus defender

I think i solved the problem, thank you so much for that @ben.turner

Now when I try to use a blueprint i have this problem in in process, can you help me with this

Screen Shot 2021-12-10 at 3.42.13 PM

Screen Shot 2021-12-10 at 3.42.29 PM

Have you restarted Local and/or the computer after tweaking the Avast configuration?

If that doesn’t fix things by clearing out any stale file handles, then can you click the “Download Local Log” button on the “Support” tab and upload the file that Local creates for you?

In addition to that log, can you also try creating a new, plain WordPress site (ie, not from a Blueprint)? Let us know if that plain site is able to be created too!

Yes @ben.turner after everything i restarted my laptop.

I can create a new site perfectly, I can create a new blueprint from a website.

I’m going to send you my blueprint with the error, maybe you can import in your environment.

local-logs.zip (12.8 KB)

I think the problem is more of the file, because i tried with another external blueprint and it’s working, I’m talking with the creator of the blueprint maybe he can solve the problem.

I’m going to update the status when I have news about this file.

Thank you for your help.

I was able to import that site into my instance of Local. Let us know what you find!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.