Failed to install wordpress on Local by Flywheel

I am using Local by Flywheel and I have installed 5 Wordpress sites with it. They work fine.
All of a sudden I cannot create another site anymore and I continuously receive this error message:

This happened even after I downloaded the latest version of Local by Flywheel released on May 20, 2020.

Here is the Local Log below.

local-lightning.log (851.1 KB)

I tried searching the forum, but I did not get any answers because I seem to have a strange error: “Too many positional arguments: ng” That “ng” is just my last name!!!

I am not a techie, so technical jargon might not help.
Thanks in advance!

Am having the same problem too

I’m new to Local. And I tried installing wordpress on Local with little success. Same error as Juicy_Jedi. Any solution?

From the error, it looks like it might be an issue with trying to designate a WP user containing a space in the username. You might try dennis-ng and see if that works.

Thank you for this response. Will try your suggestion.

I had the same problem adding a website and luckily found this thread so I could solve it. I had used a username with space in it.

The solution of @afragen works, but also local has worked with space before, so it seems introduced in an update.

When I google this problem I find it may have something to do with missing quotes somewhere in the code. Perhaps something flywheel can look into. If a space is allowed by the entry field and wordpress itself, then it should be processed right or lead to more user friendly messages. So it is a bug either way.

Thanks for a working solution @afragen

Having the same issue. Any help?

local-lightning.log (11.7 KB)

try this …
1-go to dirctory path of Local app
C:\Program Files (x86)\Local
2- open resources foder
C:\Program Files (x86)\Local\resources\extraResources
3- extract here wordpress.tar.gz file then enjoy

1 Like

Note I had this same error. I didn’t have spaces in the user name, but did in the password. Spaces are allowed in WP passwords but not in Local WP installs. Gives the error

Command failed:
Error: Too many positional arguments: 2.0*

Took out the spaces in the password and install worked.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.