File Changes Not Reflected in Browser

Issue Summary

I made several edits to a page-template in my theme then saved the file and refreshed my browser to find the changes were not reflected in the browser.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    • This was only experienced on one site, it was only tested in one site.
  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?
    • Perhaps, but that was not one of the steps I took to resolve this problem.


Change a file and refresh the browser.

System Details

  • Which version of Local is being used?

    • V 6.1.8+5621
  • What Operating System (OS) and OS version is being used?

    • macOS Big Sur 11.6

Things I’ve tried:

  1. Review local log for errors - no errors present.

  2. Stop and restart site in Local - no change

  3. Stop site, quit local, reopen local, restart site - no change

  4. Stop site, quit local, close Chrome, reopen local, restart site - no change

  5. Check site in Safari - issue repeated safari

  6. Stop site, quit local, restart computer, open local, start site - issue persisted

  7. Compare files in editor to files in finder - files match and nothing looks out of the ordinary.

  8. Review Local Community Support and Bug topics for similar issues - none found

  9. Change different php file x2 - no change detected from these files either.

  10. Pull ico file from WP Engine to Local - I was hoping this would reload things under the hood, but the files were still not showing as updated in the browser.

  11. Log in to site - saw the changes I expected when I navigated to the front end.

  12. Log out of site - saw the same “stuck” (pre changes) file on the site.

  13. Log back in and continue work on file.

I am curious if anyone else has experienced this issue and if so, how they were able to resolve it.

I am able to continue working while logged in for now.

Brief update:
After just a few minutes of working with the file, I am experiencing the issue even when logged in.

Another brief update. Additional things I’ve tried:

Purged OP cache in WP Rocket

Deactivate the WP Rocket plug-in, stop the site, and restart the site.

Checked theme editor and confirmed changes are not present

That seems like a theme level issue, and from the description, it seems like it’s due to caching. Is there any change if you try viewing the site with a different browser?

Another update. More things I’ve tried:

Turn Router Mode in advanced settings to localhost.

Copy theme files to a safe location on my machine. Uninstall Local.

Reinstall local.

Uninstall local, delete local site folder, empty trash

Reinstall local.

Disconnect site, delete site, pull site from WP engine to local.

Hello @ben.turner, thank you for your question.

Yes. I primarily use Chrome for development so I viewed the site in Safari to see if the issue was persistant. I see the same unexpected behavior in Safari as I experience in Chrome.

Another Update. More things I tried:

Move theme files to a safe location and pull entire site from develop including DB.

Disconnect site, delete site, remove local application, remove local sites folder, remove local folder from library:

Redownload, reinstall local, reconnect with new API key to WP Engine.

Test that file changes are detected by theme from pull - they are! YAY!

Override existing theme files with reserved theme files.

Test that file changes are being detected - Yes so far! YAY success!

I found this article about caching issues for another user that is very similar to my problem, but they were able to confirm it was an issue with their theme. However, I am not using the same theme and the problem seems to be resolved without any change to my theme files. I am fairly certain that the issue was somewhere in Local caching, but I was unable to discover it.

I will keep this post updated if there are any further developments to share. Thank you for reading :slight_smile:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.