Fix problem of etc/hosts file in Windows 10?


With Windows 10 and soft version1.4.3 : How to fix the problem of “Local by flywheel is requesting adminstrative privilege to modify your etc/hosts file.” ?

This problem is when you try to create or to fix WordPress installation.

thks for your answer

Hi @jona,

Local will request administrative privileges every time when /etc/hosts needs modified.

After adding the site is everything working for you or is the site not responding?

Website are green on Local interface but no access to it (admin also). Even i run “Local” as administrator same problem of “privilege”. I run Local on windows 10. need more information ?

Same problem here, Local has never functioned since the first beta came out.

Hi @jona and @Jebble,

Where is Local installed on your computer? Is it in a drive other than C:?

It’s installed with all the default settings so on C:
It’s also set to run as admin but that doesnt help either.

1 Like

Appreciate the fast reply!

So, when you add a site do you ever get an elevation prompt or do you only see the notification in the bottom right? Also, what setting is your UAC set to?

You have to be kidding me. I’m making a screenshot for you and remember that after that Local always tells me WP wasn’t configured correctly and then the sites never work. Ofcourse for the first time ever my Local site is now running…

Anyhow, this is what is shows

Hey, glad to hear it’s working though! :smile:

Please let me know if you run into anything else.

I forgot that most of my problems are on my office PC, which is almost the same though with all the same software and anti virus running. I’ll have another look at that soon as well :slight_smile:

Hi Clay,

Sadly all my problems are indeed on my Office PC. Glad to see it’s at least working on my personal one :)!

I’ve tried creating several local sites with the following options

  • With and without spaces/hyphens in the name and domain
  • PHP 5.6 and PHP 7
  • Apache
  • Local installed on C:\
  • Installing sites in ~\Local Sites,sitename>

They all give me a WordPress setup error and the websites give me a “Connection refused (ERR_CONNECTION_REFUSED)” page. I can’t tell if the problem lies within the host but I don’t think so personally.

I’ve also attached the LOG file for today trying to install 3 different sites with above parameters.
local-flywheel-log-apr-12.log (54.6 KB)

I’m not in a rush but it'd be amazing if this issue could be addressed.
In case you need any other info from this pc please let me know.

Worked it out yet? i have the same problem… 1st site worked and after that i can’t make new websites

My hosts files are working fine now but I do have to restart my sites every ten minutes or so otherwise i get an ERR_CONNECTION_REFUSED

Hi, any solution for this issue?

Have you tried updating to Local 2.0.4?

Hi, any solution for this issue?


Can you please provide the error that you’re seeing in Local?

Also, please provide your local-by-flywheel.log file if possible. See
"How do I retrieve Local’s log file?" for instructions on how to do so.


Here’s my problem problem

local-by-flywheel.log (274.0 KB)


Everything in the log and screenshot looks correct regarding the hosts file modification. This is a required step at this time.

Are you able to access the Local site in your browser?


Can you please provide your log and a screenshot of what you’re seeing?