Having a Hard Time Moving Wamp to LocalWP

What issue or error are you experiencing?

New user here.

Really struggling moving a site from WAMP to LocalWP. I copied the whole WAMP folder to an external drive and exported the database through MYSQL as a .SQL file.

I tried creating a site on localwp, deleting out the files in the public directory and copying in the files within the local directory. Having memory exceeded errors on importing the DB, updated the php.ini files and still an issue. Tried using site shell and received ACCESS DENIED errors.

I managed to get the site back somehow recreating a new install and only copying wp-content. But then tried to copy admin file and something else and it’s broken. Tried again and can’t get that far.


What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc


System Details

  • Local Version:

Latest

  • Operating System (OS) and OS version:

MAC


Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @oliver1

If you bundle up the WP-Content and SQL into their own zip file and just drag and drop them into Local, does that work, or do you get errors?

From the rest of your description, it sounds like you were trying the manual steps here, correct?

Manually Import a Local Site

What do you mean by the “admin” file? The database or something else?