Local Community

Help please, site is gone

Hello there,

I am a relatively new Local user. I have been working on a single site in Local during the past month. Today when re-opening the Local application, the site does not show up for some reason.

When opening the Local app, the site is gone and the notification is “it looks like you haven’t created any sites yet!”. This happened before the latest update. I updated the app in the hope that it will help, but the site is still gone.

What can be done to resurrect the site? I am using Windows 10 if that matters. The log file is attached.

Many thanks,

Michal

local-lightning.log (163.3 KB)

Hey @noriktal, welcome to the community and I’m sorry you’re dealing with this!

  • What version of Local are you using? Did you recently update to a new version of Local? If so, what version were you on and what version are you on now?

  • Can you please provide your Local Log? See this Community Forum post for instructions on how to do so:

  • Are you able to create a new, plain WordPress site?

As a test, if you download and manually install the 5.9.3 version of Local:

Regardless of if it works or not, I’d love to have an updated version of the Local log in order to see what things Local is reporting as you are testing. Thanks!

Hello Ben,

Here are some answers:

*What version of Local are you using?..

I updated to version 5.9.7 yesterday, yet the problem started before that, with the older version, and persisted with the new version. I am not sure what was the older version, but I downloaded the Local app about a month ago, so I guess it was the next-to-newest version.

*Local log- attached.
local-lightning.log (224.1 KB)

  • Are you able to create a new, plain WordPress site?
    yes.

*As a test, if you download and manually install the 5.9.3 version of Local.

I installed the 5.9.3 version. My site is still not there (but the test site created in the last step with 5.9.7 is there).

I hope these answers help to understand what is the problem. Like other users who wrote in the forum with a similar problem, I desperately need access to my site.

Thanks,

Michal

When you updated yesterday, how was that done? Did Local prompt you to update and you followed those prompts, or did you manually download the latest version and install it?

Since the new, plain site still exists after downgrading, maybe the original site’s files are still on the disk, but not registered with Local.

If you navigate to where the site folder, do you see the original site that went missing? If the old version of Local was using the default location, you can get there by:

  1. Selecting the new, plain site in Local
  2. Clicking the “arrow” next to the site path to open the file explorer
  3. Navigate “one folder up” to see if there are other sites there that Local doesn’t know about

Here’s a screenshot to help visualize:

If there are site files for the lost site, can you try restoring the site to a new one in Local by following the steps outlined in the “Restoring From Only Local Site files” section of this help doc:

Hi again,

I see the original site’s files in the default location on my computer. When trying to zip the folder in order to import it to the Local app, I notice something strange- I can’t zip it for some reason (there is no error message, but nothing happens). This is strange because I can zip any other folder, including the folder of the new test site.

So, something must have changed in the properties of the original site’s folder?

Any idea how to go on from here? without zipping the folder I can’t move on to importing the site.

Thanks again,

Michal

How large is the site? It’s possible that the computer is “working” but because there’s a lot of data, it’s taking a long time to create the zip.

When you examine the properties of that folder, what do you see? Are there any permissions that have changed or are different than the other site folders?

Hi,

The problem was probably the size of the folder. I managed to compress it with WinRAR, and then the import to the app worked, and the site is now accessible again.

Thanks for your help,

Michal

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.