Local Community

My site has disappeared

hello
please how to recover my site it disappeared in the local application
when I open the application it is not displayed anymore and they ask me to create a new site

I need help

Hi @metafoot - Local stores sites in your home directory in a folder called “Local Sites”. For example, mine are located at: Users/austin.wendt/Local Sites

Do you see your site in that folder? Or have you made changes in Local lately?

1 Like

Hi, i have the same problem. I find the folder you are talking about but I don’t know what to do next in order to send my site back in Local app and be able to activate it.

Thanks in advance!

Hi, Austin, could you be so kind to me and help me fix the same issue? Here are the logs:
local-logs.zip (34.3 KB)

Hi @sunrisedvision - I am looking at your log file.

When you open your Local Sites/ folder, do you see your site files? Can you show me the contents of that folder? For example, here is what mine looks like.

Looks like it’s all there. But I don’t know how to reach it and use it when the sites doesn’t show in Local app.

Interesting - the good news is the site is all there, we can see it.

My assumption is that the reinstall of Local wiped the site’s configuration file (on Windows, this is in AppData\Roaming\Local\sites.json). If you go to that location, do you have a sites.json file? If so, is it empty?

I’ve been trying to put my machine into a similar state, and found a couple of options for fixing this. It seems like we’re in different time zones, so rather than try too much back and forth, I’ll throw them out there in case you want to try both:

  1. Try zipping the entire site (for you, qatar2022) folder and attempting to import that into Local. You can either drag the .zip file over Local, and it will start the import for you, or you can go File > Import and select the file. This may/may not work depending on the state of the DB.
  2. Create a new site in Local with a new name (for example, qatar2022-new). Local will create a new site from scratch in the Local Sites folder. You can copy over the app folder from qatar2022 to qatar2022-new and launch the site in Local again.

It is a bit cumbersome, but it has gotten me out of the same issue. I’ll keep digging on what happened to that sites.json file in the first place…

Both ideas were great but unfortunately none of them worked.

  1. The zipping went very well and all the files seemed imported until at the end this error occurred.
    2022-05-20_17-09-11

  2. Creating a new site also failed because when I tried to start the new site with the imported original App folder the site didn’t worked because:

I’m starting to give up. It seems like it won’t be possible to put all the pieces together and get the site back.
I’d like to thank you for taking the time to assist me. It’s really appreciated.