How to accomodate the Local directory structure?

Local site export has a structure that differs from a standard one. i.e.

— app
—— public
—— sql
— conf
— logs

How to import a site with that structure to a server which only recognizes ‘public_html’ is a root folder? I’ve tried importing ‘public’ folder only and renaming it to ‘public_html’, but it didn’t help

Hey @tochkinade, Welcome to the Local Community Forums!

It’s hard to say exactly because each remote host is different. In many cases, all you need to do is upload the files that are within the public/wp-content folder since most WordPress-focused hosts will manage the actual WordPress files for you.

This topic has some good general information about deploying a Local site to a generic hosting provider:

Hey @ben.turner!

I’ve uploaded the ‘public’ folder. The website works, but it only displays a raw theme page as if no plugins have been installed and the entire content of the website is missing.

What’s the role of all the folders and files that are not in the ‘public’ folder (the role of .sql is clear, of course)?

I’ll take a look at the thread you’ve referred to. Thank you!

Uploading the files is part of the process. You’ll also need to migrate the content for the site which is contained within the database.

You can try importing the raw SQL files that are part of the export. Another option would be to use a plugin to help sync those database changes. Something like this would help sync the DB, but there are other options too:

Another option is if you end up hosting with WP Engine or Flywheel, all of this hassle of deploying a site is taken care of with the Connect feature.

Oh, I did migrate the database too. And I’m not getting any ‘database connection’ errors

The only other thing that comes to mind is that maybe there’s a different Database table prefix being used on the Local site than what’s on the remote site.

This help doc is WP Engine specific, but many of the steps can be done on other hosts too:

Basically, you want to see what the $table_prefix is within the Local site’s wp-config.php file and make sure the remote site is using the same table prefix.