Local Community

I can't access my database. Can anyone help?

Issue Summary

I am new to all of this and have run into problems. I changed the site domain name and now I can not access my site or database. I have changed it back to the original and all it will bring up is the Microsoft edge home search page. The WP site does not recognize any of my emails. (I have another site that I have been working on that still works fine) I am trying to go live but I can’t get it to download either.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?

Replication

Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

System Details

  • Which version of Local is being used?

  • What Operating System (OS) and OS version is being used?

    • For example: macOS Catalina or Windows 10 Professional
  • Attach the Local Log. See this Help Doc for instructions on how to do so:

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi there, Jessica! Welcome to the Local Community :wave:

Thank you for your question.

It might be helpful to record a screen-share video of what you are experiencing - you can do that for free with Loom.

I’m not sure what you mean by “The WP site does not recognize any of my emails.” can you clarify that?

Thank you!

:woman_technologist:t3: Sam

Video of the 1st site. Loom | Free Screen & Video Recording Software

WP does not recognize my email as user name.

Now the second site is having problems. Video of 2nd site. Loom | Free Screen & Video Recording Software

Hi there, Jessica!

Thank you for the videos - it’s so helpful to see what you’re looking at.

I’ve got a few questions / things to try:

  1. Have you tried creating a brand new site with default settings - does that work or do you experience the same behavior?

  2. Perhaps something has gone wrong on the wp_options side of things - let’s check on the siteurl and home values.

If you navigate from the site in Local to Database > Open Adminer > wp_options > Select Data…

What do you see under siteurl and home? Is it the correct URL? (see screenshot)

Shared with CloudApp

Let me know what you see & if you’re able to get a new site up and running.

We’ll figure this out together!

:woman_technologist:t3: Sam

Thank you for your response. I can’t log into the Adminer. I have tried to create a brand new site and it gives me an error message.

Hi @zjtripp - uh oh!

What is the error message you receive when trying to create a new site? Feel free to provide a screenshot or another video.

:woman_technologist:t3: Sam

I was able to create a new site this morning.

Now what do I need to do? Upload the old site?

Hi, @zjtripp - glad to hear you can create a new site now.

Are you able to export the site you were working on? Here’s how to do that:

:woman_technologist:t3: Sam

I can not export. It is grayed out.

I do have a file of the site however when I try to import it, I get this error.

Hi there @zjtripp - thank you for the screenshot!

What contents are included in the file of the site?

In order to import into local you will need both the wp-content folder as well as a database sql dump. See this help doc around Importing into Local:

Sam :woman_technologist:t3: