Uh-oh unable to provision a site - which I backed up using local export

Issue Summary

Prior to trying to rename site domain on local, I did export to backup (just in case). I tried repeatedly to change domain name without success. I read in forum that I could just import my back up and change the domain then. So, I deleted my site and imported the backup. That doesn’t work either. I get the error message “Can’t create database ‘local’ because, database exists”.

When I exported for backup, I assumed it would back up data base in a way that would let me import the site…

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    I only have one site in local (or I used to until I deleted it before importing.)
  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?
    I was able to create a plain WP site.


Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

System Details

  • Which version of Local is being used?

  • What Operating System (OS) and OS version is being used?

    • For example: macOS Catalina or Windows 10 Professional
  • Attach the Local Log. See this Community Forum post for instructions on how to do so:

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Also, I get notification that "Local is requesting administrative privilege’s to modify your etc/hosts file. I do get the pop that allows me to click ok. But end result is database exists as described above.

Thing that is confusing is of course the database exists. It was part of the backup. I can see it in the folder.

Well…solved the hard way.

After uninstalling and reinstalling Local, I was able to import site and change the domain name (which is what started all this). And, I was able to create a new site from a blueprint.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.