I need help! Can't get Local running on My MacOs High Sierra

Hi there,

I am new to Local Sites. I can’t get my site to connect on local.

My operating system is MacOs High Sierra.

I got a “Warning! Missing Hosts entry. This site may be inaccessible.”

Also, when I click on the “Fix It” button in that top bar, nothing happens.

I am attaching my Local Log, Router Log File and screen shots.

local-lightning copy.log (75.7 KB) logs copy.zip (451 Bytes)

Is the key error. Do you have a writable file at /etc/hosts?

You can check the permissions for this file by using the following terminal command,
ls -la /etc/hosts

The following is what shows on my computer.

➜  AJF-MBA-M1: ~ ls -la /etc/hosts
-rw-r--r--@ 1 root  wheel  1747 Jan  6 20:56 /etc/hosts

@francombat this is the 8th time you have hijacked an issue. Please stop.

You’ve made 2 yourself, that’s good. They were identical, that’s bad.

Really sorry about it, but I tried everything and I don’t know how to get some help :frowning:
How do I get help?

Thank you!

Hi Clay,
I was wondering if you can assist me with the same issue I am having with:

Warning! Missing hosts entry. This site may not be inaccessible.

logs copy.zip (454 Bytes) local-lightning copy.log (61.2 KB)

@francombat – Thanks for your patience with this!

I’m sorry that you’re having issues getting a site created in Local, but let’s see if we can get you up and running!

I know that there’s a lot of noise in this topic now that I’ve consolidated the various replies into one place. Please use only this topic while getting to the bottom of this issue

First off, were you able to take a look at afragen’s question:

Zooming out a bit, usually the Hosts file is locked due to some sort of security setting or antivirus software. You might take a look and temporarily disable any antivirus software that is installed and try creating a new site that way.

This FAQ is for Windows specifically, but you might read through it to get a general idea of how to get things working under macOS:

Either way, let us know what you find as well as the things that you’ve tried while attempting to fix this!

Dear Ben,
Thank you for your help.

I don’t seem to have any sort of security setting or antivirus on.
I am attaching the screenshot about Read only, as you can see it is settled a Read & Write, I believe it is right?

Not sure what to do now. Should delete Local and start again…

Read everything in this issue. Start from the top. You have not checked the correct item.

How do I get to see the "writable file at /etc/hosts ? "

How do I can check the permissions for this file by using the following terminal command,
ls -la /etc/hosts ?

Not a tech guy…

Copy that command into the Terminal.app and paste the results here, just as I did above.

Francombats-MBP:~ Francombat$ ls -la /etc/hosts

ls: /etc/hosts: No such file or directory

Francombats-MBP:~ Francombat$

Type the following into the Terminal.app

sudo touch /etc/hosts

It will ask for a password. You need to enter the administrative password for your computer.

I only see a key logo

Just google it and I just did enter the password, then enter. Here is what I got

You need to enter the administrative password for the computer.

I am on the terminal. And they ask me to enter the password…Where do I do it, I did and nothing happened. Google say to just enter it without seeing the password entering, then click enter and that is what the screenshot happened…

I just reenter it again. And that is what I got.

Screen Shot 2021-01-08 at 3.32.48 PM

Yes. I did what you told me to do and that’s the result I got.