Import failed. Is there a size limit on imported sites?


I’m loving LOCAL and slowly migrating all my MAMP Pro sites over.

All of the ones I have imported have worked flawlessly but I just tried to import a large site (just the /wp-content folder and .sql db file in a zip) and got this error:

Error Importing Site
We couldn’t figure out what to do with the import file provided. Please extract it manually.

In all of the other threads about this, people were not formatting their zip correctly but this is not the case here. Is there a size limit on imports (or the db itself?). The wp-content folder is 8GB and the db is 60MB. The total .zip size is 8.13GB.

Is there anything else that could cause the import to fail? I’d hate to not be able to use LOCAL for this site.


Hi Joshua,

There’s no hard cap in Local, but the process may be running into some other limit.

Is this macOS or Windows?

Also, can you provide the log file for Local? You can find it by going to Help » Reveal Local’s log on macOS and by clicking the menu icon in the top left and going to Reveal Local’s Log on Windows.

Hi Clay,

This is macOS Sierra 10.12.6/16GB RAM/MacBook Pro Retina, mid-2015.

This is the entry in the log which is totally not helpful:

Aug 14, 2017, 2:38 PM CDT - info: [renderer/ImportSiteAnalyzePage] Message from import-site-analyze-worker: unknown

All that said, I was able to get it to import by using the Duplicator plugin and exporting from there.

Why it didn’t work with the zip I created with the wp-content folder and .sql file using the macOS built-in ‘Compress’ function I don’t know but LOCAL obviously didn’t like something in the zip that I created that way.

While I was able to import the site, I don’t think this is resolved yet as the original issue still exists.


Interesting! Glad you got it imported with Duplicator.

Just to double-check, was the SQL a raw SQL file and not .sql.gz for instance?

Yep just a regular .sql file exported through MAMP Pro via phpMyAdmin.

As I mentioned, I’ve imported at least 10 sites to LOCAL previously this way without issue.