Install issues with openSUSE Leap 15.1

I can’t make the tool work on my OpenSuse, the ncurses-compat-libs library that exists in the rpm package worked perfectly on my Fedora. I wonder if there would be any procedure for it to work in opensuse. Thanks

Hi @tiagobernard,

Thanks for the report! I’ll try this out in a VM.

Thanks Clay,
I really did the test on a VM with OpenSuse KDE.

Hey @tiagobernard,

I believe you! We just need to reproduce the issue so we can have a tight feedback loop when working on the fix. :smiley:

By the way, what version of openSUSE are you using?

1 Like

Hello Clay!
I am very grateful that you are committed to solving.
I use OpenSuse Leap 15.1


1 Like

Hi @tiagobernard,

I was able to get it to install on openSUSE Leap 15.1 by doing the following:

Note: You’ll need Local 5.1 or newer so you have access to the Localhost Routing Mode.

  1. Run sudo zypper install libncurses5
  2. Run
    sudo rpm -i /PATH/TO/LOCAL/RPM/local-beta-5-2-0-b1870-linux.rpm --nodeps
    --nodeps is the important piece since the RPM is looking for ncurses-compat-libs like you mentioned.

One Local is installed, go to Preferences » Advanced and change the “Routing Mode” to “localhost”. Setting the Routing Mode to localhost disables Local’s nginx routing layer which bypasses some issues with openSUSE not having setcap to allow Nginx to run on port 80/443 without root privileges.

Then, try to create a site.

If you want to use the Pretty Domains routing mode, you will need to install libcap-progs with zypper and ensure that /usr/sbin is part of your login $PATH (not just your shell $PATH—Local will need to see it).

Hello @clay !
I am very pleased with the result! :grinning:
At first I installed Local Beta 5.2. With --nodeps at the end of the command gave error, I got sudo rpm -i --nodeps local-beta-5-2-0-b1870-linux.rpm and choosing “localhost” as you explained above got a result satisfactory.

But choosing “Pretty Domains” in “Router Mode” and installing libcap-progs didn’t work out, it gave the same error I mentioned when opening this topic. Could you please clarify how I can work using the “Pretty Domains” option? I need to use HTTPS in some projects.



I haven’t tested this so I recommend trying this in a VM first:

Add /usr/sbin to ENV_PATH in /etc/login.defs and then restart your computer.

For more details about /etc/login.defs, see

Hello @clay !
Enjoy, we are on the right track! :wink:
But it was not possible to insert the “PATH” in etc/login.defs (the old error happens), I was successful inserting export PATH=/usr/sbin:$PATH in /etc/profile.

Well, at the moment I have it running on “localhost” as well as “Pretty Domains” and that’s great. Just made a note that the browser url is different, at the moment it is: http://test-beta-regata.local/?cache-buster=1754 I’m familiar with something like: http://test-beta-regata.local . Was it something related to PATH?

Awesome! That’s great to know that /etc/profile works.

As far as the ?cache-buster query param goes, that’s simply added to the “View Site” link so your browser doesn’t serve a cached redirect. The actual site domain is still the same as usual.

Hello Clay!
Excuse me for the delay in replying, I was enjoying a little vacation. I understood perfectly about the cache-buster, thanks for the explanation.
Well, “Local” worked perfectly on a VM, but it didn’t work on the final installation I did on my notebook. I did the same steps that I did on the VM hand I was not successful. I did Path in etc/login.defs, even so I was not successful.